CVE-2026-104150

CVE-2026-104150 is a medium-severity uncontrolled resource consumption vulnerability in @adonisjs/http-server (npm), affecting versions >= 9.0.0, < 9.1.1. It is fixed in 9.1.1, 8.2.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

AdonisJS HTTP Server: Uncontrolled Resource Consumption and Inefficient Regular Expression Complexity

Description

A Regular Expression Denial of Service vulnerability in the built-in AdonisJS slug route matcher may allow a remote attacker to block the Node.js event loop using a specially crafted URL.

This affects applications using router.matchers.slug() on a route parameter reachable by an attacker.

Details

The regular expression used by router.matchers.slug() contains adjacent greedy quantifiers with overlapping character classes:

/^[^\s-_](?!.*?[-_]{2,})([a-z0-9-\\]{1,})[^\s]*[^-_\s]$/

When the matcher receives a long string ending with a character rejected by the final assertion, the regular expression engine must evaluate many possible ways of dividing the input between the overlapping quantifiers before determining that it does not match.

This results in quadratic execution time. Testing measured an approximate complexity of O(n^1.98).

Route matchers are evaluated against attacker-controlled URL segments during routing. Therefore, an unauthenticated attacker can trigger the vulnerable expression by sending a request to a route configured as follows:

router
  .get('/posts/:slug', handler)
  .where('slug', router.matchers.slug())

Routing occurs before route and group middleware. As a result, authentication or rate-limiting middleware attached to the affected route may not prevent exploitation.

The vulnerability is limited to routes that explicitly use the built-in slug matcher.

Impact

Exploitation requires an application to expose a route using router.matchers.slug() with an attacker-controlled parameter.

A specially crafted request can cause excessive CPU consumption and block the Node.js event loop. While the expression is being evaluated, the process cannot serve other requests, including requests to unrelated routes or health-check endpoints.

Only a small number of requests may be required to consume the capacity of a worker. Reverse-proxy request-line limits reduce the maximum processing time of an individual request but do not fully mitigate the vulnerability.

Crafted input forces the application to consume excessive CPU, memory, or other resources, degrading or denying service. Typical impact: denial of service.

Affected versions

@adonisjs/http-server (>= 9.0.0, < 9.1.1) @adonisjs/http-server (<= 8.2.1)

Security releases

@adonisjs/http-server → 9.1.1 (npm) @adonisjs/http-server → 8.2.2 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixes targeting v6 and v7 have been published below.

Users should upgrade to a version that includes the following fix:

Frequently Asked Questions

  1. What is CVE-2026-104150? CVE-2026-104150 is a medium-severity uncontrolled resource consumption vulnerability in @adonisjs/http-server (npm), affecting versions >= 9.0.0, < 9.1.1. It is fixed in 9.1.1, 8.2.2. Crafted input forces the application to consume excessive CPU, memory, or other resources, degrading or denying service.
  2. Which versions of @adonisjs/http-server are affected by CVE-2026-104150? @adonisjs/http-server (npm) versions >= 9.0.0, < 9.1.1 is affected.
  3. Is there a fix for CVE-2026-104150? Yes. CVE-2026-104150 is fixed in 9.1.1, 8.2.2. Upgrade to this version or later.
  4. Is CVE-2026-104150 exploitable, and should I be worried? Whether CVE-2026-104150 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-104150 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-104150?
    • Upgrade @adonisjs/http-server to 9.1.1 or later
    • Upgrade @adonisjs/http-server to 8.2.2 or later

Other vulnerabilities in @adonisjs/http-server

Stop the waste.
Protect your environment with Kodem.