CVE-2026-104181

CVE-2026-104181 is a medium-severity missing authentication for critical function vulnerability in filament/filament (composer), affecting versions >= 4.0.0, <= 4.13.2. It is fixed in 4.13.3, 5.8.3.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Filament: Multi-factor authentication (app) management actions do not require password reauthentication

App-based multi-factor authentication management actions did not consistently require the user to confirm their current password. In particular, an authenticated session could set up app-based MFA and obtain recovery codes without password reauthentication. Disabling app-based MFA and regenerating recovery codes also accepted an existing app code or recovery code without requiring the current password. This issue does not affect email-based MFA.

If an attacker gains access to a user's authenticated session, they could enable app-based MFA and obtain recovery codes without knowing the user's password, changing the account's MFA configuration and potentially locking the legitimate user out. This issue does not by itself allow an unauthenticated attacker to sign in.

Impact

A critical operation is accessible without requiring any authentication. Typical impact: any user can invoke the privileged function.

CVE-2026-104181 has a CVSS score of 5.4 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (4.13.3, 5.8.3); upgrading removes the vulnerable code path.

Affected versions

filament/filament (>= 4.0.0, <= 4.13.2) filament/filament (>= 5.0.0, <= 5.8.2)

Security releases

filament/filament → 4.13.3 (composer) filament/filament → 5.8.3 (composer)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

filament/filament to 4.13.3 or later; filament/filament to 5.8.3 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-104181? CVE-2026-104181 is a medium-severity missing authentication for critical function vulnerability in filament/filament (composer), affecting versions >= 4.0.0, <= 4.13.2. It is fixed in 4.13.3, 5.8.3. A critical operation is accessible without requiring any authentication.
  2. How severe is CVE-2026-104181? CVE-2026-104181 has a CVSS score of 5.4 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of filament/filament are affected by CVE-2026-104181? filament/filament (composer) versions >= 4.0.0, <= 4.13.2 is affected.
  4. Is there a fix for CVE-2026-104181? Yes. CVE-2026-104181 is fixed in 4.13.3, 5.8.3. Upgrade to this version or later.
  5. Is CVE-2026-104181 exploitable, and should I be worried? Whether CVE-2026-104181 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-104181 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-104181?
    • Upgrade filament/filament to 4.13.3 or later
    • Upgrade filament/filament to 5.8.3 or later

Other vulnerabilities in filament/filament

Stop the waste.
Protect your environment with Kodem.