CVE-2026-104844

CVE-2026-104844 is a medium-severity uncontrolled resource consumption vulnerability in postcss-selector-parser (npm), affecting versions >= 7.0.0, < 7.1.6. It is fixed in 7.1.6, 6.1.5.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

PostCSS: Quadratic complexity in flat selector parsing allows CPU exhaustion

Workarounds

Cap the size of selectors accepted from untrusted sources before parsing.

Impact

. and # are not word delimiters in the tokenizer, so a flat selector such as
.a.a.a... reaches splitWord() as a single word token carrying n class or id
indexes. Three passes scanned those index arrays linearly for every index,
making the parse O(n^2) in the number of indexes rather than in input length:
uniqs(), the indices.forEach loop, and the Sass-interpolation filter.
Parsing a 400 KB flat selector took ~34 s on a modern laptop, fully occupying a
single thread. A benign selector of identical byte size parses in tens of
milliseconds, so the cost is driven by the index count, not the input size.
The nesting depth of such a selector is 0, so the maxNestingDepth guard added
in 7.1.3 offers no protection.

Reachability is deployment dependent. Only consumers that parse untrusted,
attacker-supplied selectors synchronously in a request path are exposed, for
example CSS sanitizers, CSS-in-JS services and online playgrounds. Ordinary
build-time use on trusted sources is not affected.

Crafted input forces the application to consume excessive CPU, memory, or other resources, degrading or denying service. Typical impact: denial of service.

CVE-2026-104844 has a CVSS score of 5.9 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (7.1.6, 6.1.5); upgrading removes the vulnerable code path.

Affected versions

postcss-selector-parser (>= 7.0.0, < 7.1.6) postcss-selector-parser (< 6.1.5)

Security releases

postcss-selector-parser → 7.1.6 (npm) postcss-selector-parser → 6.1.5 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in 7.1.6. The three passes now use Set membership tests, making parsing
linear in the number of indexes. There is no behaviour change: parsing is
byte-identical on a differential corpus of 8413 selectors.

Frequently Asked Questions

  1. What is CVE-2026-104844? CVE-2026-104844 is a medium-severity uncontrolled resource consumption vulnerability in postcss-selector-parser (npm), affecting versions >= 7.0.0, < 7.1.6. It is fixed in 7.1.6, 6.1.5. Crafted input forces the application to consume excessive CPU, memory, or other resources, degrading or denying service.
  2. How severe is CVE-2026-104844? CVE-2026-104844 has a CVSS score of 5.9 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of postcss-selector-parser are affected by CVE-2026-104844? postcss-selector-parser (npm) versions >= 7.0.0, < 7.1.6 is affected.
  4. Is there a fix for CVE-2026-104844? Yes. CVE-2026-104844 is fixed in 7.1.6, 6.1.5. Upgrade to this version or later.
  5. Is CVE-2026-104844 exploitable, and should I be worried? Whether CVE-2026-104844 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-104844 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-104844?
    • Upgrade postcss-selector-parser to 7.1.6 or later
    • Upgrade postcss-selector-parser to 6.1.5 or later

Other vulnerabilities in postcss-selector-parser

Stop the waste.
Protect your environment with Kodem.