CVE-2026-104873

CVE-2026-104873 is a high-severity incorrect authorization vulnerability in langgraph-sdk (pip), affecting versions >= 0.1.45, <= 0.4.3. It is fixed in 0.4.4.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

LangGraph SDK custom auth silently ignores actions= on resource decorators

Workarounds

No.

References

N/A

Impact

What kind of vulnerability is it? Who is impacted?
langgraph-sdk incorrectly applies the actions= argument on resource-scoped authorization decorators, including @auth.on.threads, @auth.on.assistants, and @auth.on.crons.

In affected versions, a decorator such as:

@auth.on.threads(actions=["create"])
async def allow_thread_create(ctx, value):
    return None

intended to register a handler for selected actions instead registers that handler for every action on the resource. Because the resource-wide handler is selected before broader fallback handlers, authorization checks implemented in those fallback handlers may not run.

An authenticated user may therefore be able to perform actions the application intended to deny, such as reading, updating, or deleting another user's resource. Exploitability and impact depend on the affected handler's behavior: deployments remain protected if that handler independently enforces the necessary action, ownership, or permission checks for every request it receives.

Only Python deployments using actions= on the affected resource-scoped decorators are affected.

The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions. Typical impact: unauthorized data access or execution of privileged operations.

Affected versions

langgraph-sdk (>= 0.1.45, <= 0.4.3)

Security releases

langgraph-sdk → 0.4.4 (pip)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

0.4.4

Frequently Asked Questions

  1. What is CVE-2026-104873? CVE-2026-104873 is a high-severity incorrect authorization vulnerability in langgraph-sdk (pip), affecting versions >= 0.1.45, <= 0.4.3. It is fixed in 0.4.4. The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions.
  2. Which versions of langgraph-sdk are affected by CVE-2026-104873? langgraph-sdk (pip) versions >= 0.1.45, <= 0.4.3 is affected.
  3. Is there a fix for CVE-2026-104873? Yes. CVE-2026-104873 is fixed in 0.4.4. Upgrade to this version or later.
  4. Is CVE-2026-104873 exploitable, and should I be worried? Whether CVE-2026-104873 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-104873 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-104873? Upgrade langgraph-sdk to 0.4.4 or later.

Other vulnerabilities in langgraph-sdk

Stop the waste.
Protect your environment with Kodem.