CVE-2026-105650

CVE-2026-105650 is a high-severity cross-site scripting (XSS) vulnerability in ghost (npm), affecting versions >= 2.5.0, < 6.64.0. It is fixed in 6.64.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Ghost: Stored XSS via oEmbed Photo Responses

Vulnerable versions

This vulnerability is present in Ghost from v2.1.0 up to v6.64.0.

How to update

For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.

If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.

References

Ghost thanks SecBuddyF of Tencent KeenLab and Nhat Anh Vu for disclosing this vulnerability responsibly.

For more information

If you have any questions or comments about this advisory, email us at [email protected].

Impact

Embedding a URL from an attacker-controlled website could result in untrusted scripts being stored in post content. These scripts could run in the Ghost editor, on the published site, and in newsletter emails, possibly resulting in compromise of a staff user's admin session.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

CVE-2026-105650 has a CVSS score of 8.1 (High). The vector is network-reachable, no privileges required, and user interaction required. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (6.64.0); upgrading removes the vulnerable code path.

Affected versions

ghost (>= 2.5.0, < 6.64.0)

Security releases

ghost → 6.64.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

v6.64.0 contains a fix for this issue.

Frequently Asked Questions

  1. What is CVE-2026-105650? CVE-2026-105650 is a high-severity cross-site scripting (XSS) vulnerability in ghost (npm), affecting versions >= 2.5.0, < 6.64.0. It is fixed in 6.64.0. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. How severe is CVE-2026-105650? CVE-2026-105650 has a CVSS score of 8.1 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of ghost are affected by CVE-2026-105650? ghost (npm) versions >= 2.5.0, < 6.64.0 is affected.
  4. Is there a fix for CVE-2026-105650? Yes. CVE-2026-105650 is fixed in 6.64.0. Upgrade to this version or later.
  5. Is CVE-2026-105650 exploitable, and should I be worried? Whether CVE-2026-105650 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-105650 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-105650? Upgrade ghost to 6.64.0 or later.

Other vulnerabilities in ghost

Stop the waste.
Protect your environment with Kodem.