CVE-2026-105678

CVE-2026-105678 is a medium-severity improper privilege management vulnerability in ghost (npm), affecting versions >= 0.5.0, < 6.64.0. It is fixed in 6.64.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Ghost: Editors Could Promote Staff Users to Their Own Role

Vulnerable versions

This vulnerability is present in Ghost from v0.5.0 up to v6.64.0.

How to update

For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.

If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.

References

Ghost thanks SecBuddyF of Tencent KeenLab, Santosh Kumar Puppala, Pedro Pinho, and Nhat Anh Vu for disclosing this vulnerability responsibly.

For more information

If you have any questions or comments about this advisory, email us at [email protected].

Impact

Staff users with the Editor or Super Editor role were able to assign their own role to Author and Contributor users, despite not having permission to assign that role.

The application assigns, modifies, tracks, or checks privileges incorrectly, allowing a user to gain elevated access. Typical impact: privilege escalation beyond the intended level.

CVE-2026-105678 has a CVSS score of 4.3 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (6.64.0); upgrading removes the vulnerable code path.

Affected versions

ghost (>= 0.5.0, < 6.64.0)

Security releases

ghost → 6.64.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

v6.64.0 contains a fix for this issue.

Frequently Asked Questions

  1. What is CVE-2026-105678? CVE-2026-105678 is a medium-severity improper privilege management vulnerability in ghost (npm), affecting versions >= 0.5.0, < 6.64.0. It is fixed in 6.64.0. The application assigns, modifies, tracks, or checks privileges incorrectly, allowing a user to gain elevated access.
  2. How severe is CVE-2026-105678? CVE-2026-105678 has a CVSS score of 4.3 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of ghost are affected by CVE-2026-105678? ghost (npm) versions >= 0.5.0, < 6.64.0 is affected.
  4. Is there a fix for CVE-2026-105678? Yes. CVE-2026-105678 is fixed in 6.64.0. Upgrade to this version or later.
  5. Is CVE-2026-105678 exploitable, and should I be worried? Whether CVE-2026-105678 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-105678 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-105678? Upgrade ghost to 6.64.0 or later.

Other vulnerabilities in ghost

Stop the waste.
Protect your environment with Kodem.