CVE-2026-105795

CVE-2026-105795 is a low-severity path traversal vulnerability in Microsoft.OpenApi.Kiota (nuget), affecting versions >= 1.25.1, < 1.35.0. It is fixed in 1.35.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Kiota: Unsafe oauthcardpath references in Kiota-generated API plugin manifests

Affected versions

The affected NuGet packages are Microsoft.OpenApi.Kiota and Microsoft.OpenApi.Kiota.Builder, starting with version 1.25.1, which introduced this manifest field. The field remains unvalidated through version 1.34.1, including the separate 1.29.1 security-backport release. Version 1.35.0 fixes the issue.

Workarounds

Generate plugins only from trusted, integrity-protected OpenAPI descriptions. Before packaging or deployment, review generated manifests and remove any oauth_card_path that is not a safe relative reference confined to the plugin package. Do not rely on validation of sibling manifest fields to validate this field.

Related advisories

GHSA-4jwf-m4wg-8p66 and GHSA-p5rm-jg5c-8c77 cover static_template.file. Their fixes do not enforce validation at the separate oauth_card_path emission site.

Impact

When generating an API plugin manifest from an attacker-controlled or compromised OpenAPI description, Kiota copies x-ai-capabilities.response_semantics.oauth_card_path into the manifest without validating that it is a safe package-relative file reference. An attacker can supply parent-directory traversal, rooted paths, or absolute URIs instead of a card file within the plugin package.

The unsafe reference is propagated into the generated manifest. Its security effect depends on the downstream host's handling of the reference when the plugin is packaged and deployed. This is not local code execution or a file read performed by Kiota merely during generation. A consuming host that resolves the untrusted reference can cross the intended package boundary or use an unintended authentication card.

Input manipulates file paths to reach files outside the intended directory, such as configuration or credential files. Typical impact: unauthorized file read or write outside the intended directory.

CVE-2026-105795 has a CVSS score of 3.1 (Low). The vector is network-reachable, no privileges required, and user interaction required. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.35.0); upgrading removes the vulnerable code path.

Affected versions

Microsoft.OpenApi.Kiota (>= 1.25.1, < 1.35.0) Microsoft.OpenApi.Kiota.Builder (>= 1.25.1, < 1.35.0)

Security releases

Microsoft.OpenApi.Kiota → 1.35.0 (nuget) Microsoft.OpenApi.Kiota.Builder → 1.35.0 (nuget)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade to Kiota 1.35.0 or later and regenerate affected plugin manifests. Kiota now applies the existing safe-file-reference validator to oauth_card_path, drops unsafe references, and emits a warning. Valid relative card paths remain supported.

Frequently Asked Questions

  1. What is CVE-2026-105795? CVE-2026-105795 is a low-severity path traversal vulnerability in Microsoft.OpenApi.Kiota (nuget), affecting versions >= 1.25.1, < 1.35.0. It is fixed in 1.35.0. Input manipulates file paths to reach files outside the intended directory, such as configuration or credential files.
  2. How severe is CVE-2026-105795? CVE-2026-105795 has a CVSS score of 3.1 (Low). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-105795?
    • Microsoft.OpenApi.Kiota (nuget) (versions >= 1.25.1, < 1.35.0)
    • Microsoft.OpenApi.Kiota.Builder (nuget) (versions >= 1.25.1, < 1.35.0)
  4. Is there a fix for CVE-2026-105795? Yes. CVE-2026-105795 is fixed in 1.35.0. Upgrade to this version or later.
  5. Is CVE-2026-105795 exploitable, and should I be worried? Whether CVE-2026-105795 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-105795 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-105795?
    • Upgrade Microsoft.OpenApi.Kiota to 1.35.0 or later
    • Upgrade Microsoft.OpenApi.Kiota.Builder to 1.35.0 or later

Other vulnerabilities in Microsoft.OpenApi.Kiota

Stop the waste.
Protect your environment with Kodem.