Summary
Payload: SQL injection in SQLite/Postgres
You are affected if:
- You use
@payloadcms/db-sqliteor@payloadcms/db-d1-sqlite. - You use
@payloadcms/db-postgresor@payloadcms/db-vercel-postgres< 3.73.0. - A readable collection has a
jsonfield, or ablocksfield withblocksAsJSON: true. - The attacker has read plus create or update access on it.
You are not affected if:
- You have no
json orblocksAsJSONfields.richText` is not affected. - You run a patched version.
Impact
An attacker who has read plus create or update access to a collection can submit a request that includes a SQL injection targeting a specific field path shape and operators in Payload's SQLite and Postgres.
Untrusted input alters a database query, allowing the attacker to read or modify data the query was not intended to access. Typical impact: data disclosure or modification.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
The patched version sanitizes the query input to prevent injection.
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Frequently Asked Questions
- What is CVE-2026-105856? CVE-2026-105856 is a high-severity SQL injection vulnerability in @payloadcms/db-sqlite (npm), affecting versions >= 3.0.0, < 3.90.0. It is fixed in 3.90.0, 3.73.0, 4.0.0-canary.34. Untrusted input alters a database query, allowing the attacker to read or modify data the query was not intended to access.
- Which packages are affected by CVE-2026-105856?
@payloadcms/db-sqlite(npm) (versions >= 3.0.0, < 3.90.0)@payloadcms/db-d1-sqlite(npm) (versions >= 3.0.0, < 3.90.0)@payloadcms/db-postgres(npm) (versions >= 3.0.0, < 3.73.0)@payloadcms/db-vercel-postgres(npm) (versions >= 3.0.0, < 3.73.0)
- Is there a fix for CVE-2026-105856? Yes. CVE-2026-105856 is fixed in 3.90.0, 3.73.0, 4.0.0-canary.34. Upgrade to this version or later.
- Is CVE-2026-105856 exploitable, and should I be worried? Whether CVE-2026-105856 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-105856 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-105856?
- Upgrade
@payloadcms/db-sqliteto 3.90.0 or later - Upgrade
@payloadcms/db-d1-sqliteto 3.90.0 or later - Upgrade
@payloadcms/db-postgresto 3.73.0 or later - Upgrade
@payloadcms/db-vercel-postgresto 3.73.0 or later - Upgrade
@payloadcms/db-sqliteto 4.0.0-canary.34 or later - Upgrade
@payloadcms/db-d1-sqliteto 4.0.0-canary.34 or later
- Upgrade