CVE-2026-106105

CVE-2026-106105 is a high-severity incorrect permission assignment for critical resource vulnerability in @quasar/ssl-certificate (npm), affecting versions <= 2.0.0. It is fixed in 2.1.0, 5.0.4, 3.3.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Quasar Framework: Development TLS private keys are cached with overly permissive filesystem permissions

The @quasar/ssl-certificate development utility caches a combined PEM containing a generated private key and certificate without explicitly restricting its filesystem permissions. On systems with a typical process umask, the PEM can be readable by other local users. A local attacker with filesystem access could copy and reuse the private key to impersonate a development TLS endpoint in an environment that trusts the certificate.

The generated certificate was also unnecessarily CA-capable and included broad key usages beyond its localhost HTTPS purpose. Its IPv6 loopback entry was encoded as a DNS name rather than an IP subject alternative name.

The remediation writes and repairs the cached PEM with owner-only permissions on supported platforms, generates a non-CA server-auth leaf certificate with constrained key usage, corrects the IPv6 loopback SAN, and bases cache expiry on content modification time so permission metadata changes cannot extend the certificate lifetime. This issue does not expose the key remotely by itself; exploitation requires another local user to be able to read the cached PEM file.

Impact

A file, directory, or other resource is assigned permissions that allow broader access than intended. Typical impact: unauthorized read, modification, or execution of the resource.

Affected versions

@quasar/ssl-certificate (<= 2.0.0) @quasar/cli (<= 5.0.3) @quasar/app-vite (<= 3.2.0)

Security releases

@quasar/ssl-certificate → 2.1.0 (npm) @quasar/cli → 5.0.4 (npm) @quasar/app-vite → 3.3.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

@quasar/ssl-certificate to 2.1.0 or later; @quasar/cli to 5.0.4 or later; @quasar/app-vite to 3.3.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-106105? CVE-2026-106105 is a high-severity incorrect permission assignment for critical resource vulnerability in @quasar/ssl-certificate (npm), affecting versions <= 2.0.0. It is fixed in 2.1.0, 5.0.4, 3.3.0. A file, directory, or other resource is assigned permissions that allow broader access than intended.
  2. Which packages are affected by CVE-2026-106105?
    • @quasar/ssl-certificate (npm) (versions <= 2.0.0)
    • @quasar/cli (npm) (versions <= 5.0.3)
    • @quasar/app-vite (npm) (versions <= 3.2.0)
  3. Is there a fix for CVE-2026-106105? Yes. CVE-2026-106105 is fixed in 2.1.0, 5.0.4, 3.3.0. Upgrade to this version or later.
  4. Is CVE-2026-106105 exploitable, and should I be worried? Whether CVE-2026-106105 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-106105 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-106105?
    • Upgrade @quasar/ssl-certificate to 2.1.0 or later
    • Upgrade @quasar/cli to 5.0.4 or later
    • Upgrade @quasar/app-vite to 3.3.0 or later

Stop the waste.
Protect your environment with Kodem.