CVE-2026-106435

CVE-2026-106435 is a high-severity out-of-bounds read vulnerability in pymongo (pip), affecting versions >= 3.9.0, <= 4.18.2. It is fixed in 4.18.3.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

MongoDB Python Driver: Out-of-bounds read in BSON decoding via a malformed Regex element

Workarounds

Decode untrusted BSON only from NUL-terminated buffers, bytes or bytearray, and copy mmap input first, e.g. bytes(mm[:size]).

Impact

The C extension's BSON decoder scans a Regex element's pattern and flags strings with strlen before checking the document's remaining length, so a crafted truncated Regex element can read past the end of the caller's buffer. bson.decode and bson.decode_all accept mmap and array buffers, which carry no NUL sentinel; the read can cross into unmapped memory and kill the process with an uncatchable SIGSEGV. Any application decoding untrusted BSON from such buffers is affected, impact is availability only, since the out-of-bounds bytes are never returned as content. NUL-terminated buffers (bytes, bytearray) raise InvalidBSON at worst; the driver's own transport and pure-Python installs are not affected. All releases through 4.18.2 are affected when the C extension is loaded.

A read operation accesses a memory location beyond the intended buffer boundary. Typical impact: sensitive data disclosure or crash.

Affected versions

pymongo (>= 3.9.0, <= 4.18.2)

Security releases

pymongo → 4.18.3 (pip)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in PyMongo 4.18.3. Malformed Regex elements now raise InvalidBSON on every accepted buffer type; valid documents decode unchanged.

Frequently Asked Questions

  1. What is CVE-2026-106435? CVE-2026-106435 is a high-severity out-of-bounds read vulnerability in pymongo (pip), affecting versions >= 3.9.0, <= 4.18.2. It is fixed in 4.18.3. A read operation accesses a memory location beyond the intended buffer boundary.
  2. Which versions of pymongo are affected by CVE-2026-106435? pymongo (pip) versions >= 3.9.0, <= 4.18.2 is affected.
  3. Is there a fix for CVE-2026-106435? Yes. CVE-2026-106435 is fixed in 4.18.3. Upgrade to this version or later.
  4. Is CVE-2026-106435 exploitable, and should I be worried? Whether CVE-2026-106435 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-106435 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-106435? Upgrade pymongo to 4.18.3 or later.

Other vulnerabilities in pymongo

Stop the waste.
Protect your environment with Kodem.