CVE-2026-106455

CVE-2026-106455 is a high-severity server-side request forgery (SSRF) vulnerability in @backstage/plugin-techdocs-node (npm), affecting versions >= 0.11.12, < 1.14.7. It is fixed in 1.14.7, 1.15.5.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage: Improper validation of MkDocs plugin configuration in TechDocs

Workarounds

  • Restrict control of TechDocs source repositories and catalog registration to trusted maintainers.
  • Run documentation builders with outbound access to private and link-local networks denied.
  • Require token- or header-protected cloud instance metadata services.

Impact

An authenticated attacker with control over a TechDocs source repository could cause a documentation build to retrieve and publish data from network locations reachable by the build environment. Exposure depends on deployment topology, build mode, and target endpoint protections. Modern cloud metadata services that require tokens or special headers are not directly accessible through the affected behavior.

Untrusted input controls the target URL of a server-initiated request, which may reach internal services not otherwise accessible from outside. Typical impact: access to internal metadata services, internal APIs, or cloud credentials.

CVE-2026-106455 has a CVSS score of 7.7 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.14.7, 1.15.5); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-techdocs-node (>= 0.11.12, < 1.14.7) @backstage/plugin-techdocs-node (>= 1.15.0, < 1.15.5)

Security releases

@backstage/plugin-techdocs-node → 1.14.7 (npm) @backstage/plugin-techdocs-node → 1.15.5 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade @backstage/plugin-techdocs-node to a patched version for the applicable release line:

The update removes MkDocs plugins outside the built-in allowlist. To retain additional plugins, review them and configure techdocs.generator.mkdocs.dangerouslyAllowAdditionalPlugins, or supply dangerouslyAllowAdditionalPlugins when creating the generator directly. Plugins supplied through defaultPlugins remain permitted.

Frequently Asked Questions

  1. What is CVE-2026-106455? CVE-2026-106455 is a high-severity server-side request forgery (SSRF) vulnerability in @backstage/plugin-techdocs-node (npm), affecting versions >= 0.11.12, < 1.14.7. It is fixed in 1.14.7, 1.15.5. Untrusted input controls the target URL of a server-initiated request, which may reach internal services not otherwise accessible from outside.
  2. How severe is CVE-2026-106455? CVE-2026-106455 has a CVSS score of 7.7 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @backstage/plugin-techdocs-node are affected by CVE-2026-106455? @backstage/plugin-techdocs-node (npm) versions >= 0.11.12, < 1.14.7 is affected.
  4. Is there a fix for CVE-2026-106455? Yes. CVE-2026-106455 is fixed in 1.14.7, 1.15.5. Upgrade to this version or later.
  5. Is CVE-2026-106455 exploitable, and should I be worried? Whether CVE-2026-106455 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106455 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106455?
    • Upgrade @backstage/plugin-techdocs-node to 1.14.7 or later
    • Upgrade @backstage/plugin-techdocs-node to 1.15.5 or later

Other vulnerabilities in @backstage/plugin-techdocs-node

Stop the waste.
Protect your environment with Kodem.