CVE-2026-106456

CVE-2026-106456 is a medium-severity incorrect authorization vulnerability in @backstage/plugin-proxy-backend (npm), affecting versions >= 0.5.0, < 0.6.18. It is fixed in 0.6.18.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage: Inconsistent credential enforcement for overlapping proxy routes

Workarounds

  • Avoid nesting a credential-protected proxy path below a path configured with dangerously-allow-unauthenticated.
  • Apply the same credential requirement to overlapping proxy paths.
  • Restrict direct network access to the Backstage backend until the patched package is deployed.

Impact

An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy.

Exploitation requires this specific overlapping route configuration. The resulting confidentiality and integrity impact depends on the capabilities exposed by the nested upstream.

The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions. Typical impact: unauthorized data access or execution of privileged operations.

CVE-2026-106456 has a CVSS score of 4.8 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.6.18); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-proxy-backend (>= 0.5.0, < 0.6.18)

Security releases

@backstage/plugin-proxy-backend → 0.6.18 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade @backstage/plugin-proxy-backend to version 0.6.18 or later. The fixed package is available in Backstage v1.55.0.

Frequently Asked Questions

  1. What is CVE-2026-106456? CVE-2026-106456 is a medium-severity incorrect authorization vulnerability in @backstage/plugin-proxy-backend (npm), affecting versions >= 0.5.0, < 0.6.18. It is fixed in 0.6.18. The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions.
  2. How severe is CVE-2026-106456? CVE-2026-106456 has a CVSS score of 4.8 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @backstage/plugin-proxy-backend are affected by CVE-2026-106456? @backstage/plugin-proxy-backend (npm) versions >= 0.5.0, < 0.6.18 is affected.
  4. Is there a fix for CVE-2026-106456? Yes. CVE-2026-106456 is fixed in 0.6.18. Upgrade to this version or later.
  5. Is CVE-2026-106456 exploitable, and should I be worried? Whether CVE-2026-106456 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106456 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106456? Upgrade @backstage/plugin-proxy-backend to 0.6.18 or later.

Other vulnerabilities in @backstage/plugin-proxy-backend

Stop the waste.
Protect your environment with Kodem.