CVE-2026-106457

CVE-2026-106457 is a medium-severity improper authentication vulnerability in @backstage/plugin-auth-backend-module-cloudflare-access-provider (npm), affecting versions >= 0.1.0, < 0.5.0. It is fixed in 0.5.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage: Insufficient audience validation in the Cloudflare Access auth provider

Workarounds

  • Restrict access to the Backstage auth endpoint to the intended Cloudflare Access application.
  • Use a custom authenticator that validates the application audience.
  • Disable the provider until the patched package can be deployed.

Impact

The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for the Backstage application. A user holding a valid token for another Access application in the same Cloudflare Zero Trust team may therefore be able to authenticate to Backstage if that token reaches the auth endpoint without the Backstage application's audience already being enforced upstream.

Cloudflare Access normally evaluates the protected application before forwarding requests. The reported reproduction exercises the provider directly and does not demonstrate bypass through the ordinary Cloudflare-protected Backstage URL. Relevant deployment topologies include direct origin access, alternate routes around the intended Access application, or another proxy forwarding the assertion unchanged.

A successful sign-in also depends on the deployment's sign-in resolver mapping the presented identity to a Backstage user. The resulting impact depends on the permissions assigned to that identity.

The application does not adequately verify the identity of a user, device, or process before granting access. Typical impact: unauthorized access to functions or data reserved for authenticated parties.

CVE-2026-106457 has a CVSS score of 6.8 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.5.0); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-auth-backend-module-cloudflare-access-provider (>= 0.1.0, < 0.5.0)

Security releases

@backstage/plugin-auth-backend-module-cloudflare-access-provider → 0.5.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade @backstage/plugin-auth-backend-module-cloudflare-access-provider to version 0.5.0 or later. The fixed package is available in Backstage v1.55.0.

This is a breaking configuration change. Before upgrading, set auth.providers.cfaccess.audience to the Audience (AUD) tag for the Backstage application in Cloudflare Zero Trust:

auth:
  providers:
    cfaccess:
      teamName: example
      audience: ${AUTH_CFACCESS_AUDIENCE}

Frequently Asked Questions

  1. What is CVE-2026-106457? CVE-2026-106457 is a medium-severity improper authentication vulnerability in @backstage/plugin-auth-backend-module-cloudflare-access-provider (npm), affecting versions >= 0.1.0, < 0.5.0. It is fixed in 0.5.0. The application does not adequately verify the identity of a user, device, or process before granting access.
  2. How severe is CVE-2026-106457? CVE-2026-106457 has a CVSS score of 6.8 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @backstage/plugin-auth-backend-module-cloudflare-access-provider are affected by CVE-2026-106457? @backstage/plugin-auth-backend-module-cloudflare-access-provider (npm) versions >= 0.1.0, < 0.5.0 is affected.
  4. Is there a fix for CVE-2026-106457? Yes. CVE-2026-106457 is fixed in 0.5.0. Upgrade to this version or later.
  5. Is CVE-2026-106457 exploitable, and should I be worried? Whether CVE-2026-106457 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106457 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106457? Upgrade @backstage/plugin-auth-backend-module-cloudflare-access-provider to 0.5.0 or later.

Stop the waste.
Protect your environment with Kodem.