CVE-2026-106459

CVE-2026-106459 is a high-severity server-side request forgery (SSRF) vulnerability in @backstage/plugin-scaffolder-backend-module-sentry (npm), affecting versions >= 0.3.0, < 0.3.8. It is fixed in 0.3.8.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage: Improper input validation in Sentry scaffolder actions

Workarounds

  • Disable the affected actions until the patched package is deployed.
  • Restrict scaffolder.action.execute permission for the affected Sentry actions to trusted users and templates.

Impact

An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token.

Untrusted input controls the target URL of a server-initiated request, which may reach internal services not otherwise accessible from outside. Typical impact: access to internal metadata services, internal APIs, or cloud credentials.

CVE-2026-106459 has a CVSS score of 8.5 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.3.8); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-scaffolder-backend-module-sentry (>= 0.3.0, < 0.3.8)

Security releases

@backstage/plugin-scaffolder-backend-module-sentry → 0.3.8 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade @backstage/plugin-scaffolder-backend-module-sentry to version 0.3.8 or later. The fixed package is available in Backstage v1.54.8 and Backstage v1.55.0.

The update removes custom action-level apiBaseUrl values. Move any such value to scaffolder.sentry.apiBaseUrl before upgrading.

Frequently Asked Questions

  1. What is CVE-2026-106459? CVE-2026-106459 is a high-severity server-side request forgery (SSRF) vulnerability in @backstage/plugin-scaffolder-backend-module-sentry (npm), affecting versions >= 0.3.0, < 0.3.8. It is fixed in 0.3.8. Untrusted input controls the target URL of a server-initiated request, which may reach internal services not otherwise accessible from outside.
  2. How severe is CVE-2026-106459? CVE-2026-106459 has a CVSS score of 8.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @backstage/plugin-scaffolder-backend-module-sentry are affected by CVE-2026-106459? @backstage/plugin-scaffolder-backend-module-sentry (npm) versions >= 0.3.0, < 0.3.8 is affected.
  4. Is there a fix for CVE-2026-106459? Yes. CVE-2026-106459 is fixed in 0.3.8. Upgrade to this version or later.
  5. Is CVE-2026-106459 exploitable, and should I be worried? Whether CVE-2026-106459 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106459 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106459? Upgrade @backstage/plugin-scaffolder-backend-module-sentry to 0.3.8 or later.

Stop the waste.
Protect your environment with Kodem.