Summary
Backstage: Explicit negative email verification can be ignored during shared OAuth profile normalization
Workarounds
- Require the identity provider to verify user-controlled email addresses before allowing sign-in.
- Ensure profile emails are immutable and provisioned from a trusted organizational source.
- Use a sign-in resolver that does not depend on the profile email.
- Use a custom profile transform that omits an email when matching provider metadata explicitly marks it as unverified.
Impact
Several Passport-based authentication providers use shared OAuth profile normalization from @backstage/plugin-auth-node. Affected versions may pass an email to email-based sign-in resolvers even when verification metadata supplied for that same address is explicitly negative. The ID-token-only fallback likewise did not consistently respect email_verified: false.
Exploitation requires a deployment where an admitted identity-provider user can supply or change an email address without verification and Backstage uses that profile email to resolve catalog identities. In that configuration, the user may be able to assume another catalog identity and obtain its associated access and permissions.
An absent email_verified claim is not by itself considered an affected condition. Some providers rely on authoritative organizational provisioning and intentionally omit the optional claim. Operators using email-based sign-in resolution must ensure that the configured provider restricts sign-in to the intended user population and supplies an authoritative email address, either through provider verification or trusted immutable provisioning.
This advisory covers the shared Passport profile normalization path when the selected profile email itself carries verified: false, when a matching raw provider email carries email_verified: false, or when an email obtained only from an ID token carries email_verified: false. It does not apply verification metadata from a different address or from a separate ID token to an independently fetched provider-profile email.
The generic OIDC provider follows a separate profile transform and is covered by GHSA-826h-28h9-65hg. The two advisories are complementary; deployments using both affected paths should apply both package updates. VMware Cloud uses a separate custom token transformation and is not changed by this patch.
The application does not adequately verify the identity of a user, device, or process before granting access. Typical impact: unauthorized access to functions or data reserved for authenticated parties.
CVE-2026-106460 has a CVSS score of 6.8 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.6.15, 0.7.5); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
Fixed in @backstage/plugin-auth-node versions 0.6.15 and 0.7.5. Users remaining on the 0.6.x line should upgrade to at least 0.6.15; users on 0.7.x should upgrade to at least 0.7.5.
The patched packages were released with Backstage v1.49.7 and Backstage v1.54.7, respectively. The fix is also present on master in commit 507e65a.
Frequently Asked Questions
- What is CVE-2026-106460? CVE-2026-106460 is a medium-severity improper authentication vulnerability in @backstage/plugin-auth-node (npm), affecting versions >= 0.3.0, < 0.6.15. It is fixed in 0.6.15, 0.7.5. The application does not adequately verify the identity of a user, device, or process before granting access.
- How severe is CVE-2026-106460? CVE-2026-106460 has a CVSS score of 6.8 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of @backstage/plugin-auth-node are affected by CVE-2026-106460? @backstage/plugin-auth-node (npm) versions >= 0.3.0, < 0.6.15 is affected.
- Is there a fix for CVE-2026-106460? Yes. CVE-2026-106460 is fixed in 0.6.15, 0.7.5. Upgrade to this version or later.
- Is CVE-2026-106460 exploitable, and should I be worried? Whether CVE-2026-106460 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-106460 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-106460?
- Upgrade
@backstage/plugin-auth-nodeto 0.6.15 or later - Upgrade
@backstage/plugin-auth-nodeto 0.7.5 or later
- Upgrade