CVE-2026-106562

CVE-2026-106562 is a medium-severity incorrect authorization vulnerability in @backstage/plugin-search-backend (npm), affecting versions < 2.1.6. It is fixed in 2.1.6, 1.8.7.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage has incorrect authorization in search engine permission filtering

Workarounds

If you are unable to upgrade immediately:

  • Temporarily modify permission policies to use CONDITIONAL decisions with per-result filtering rather than blanket DENY for search document types
  • Restrict Elasticsearch/OpenSearch index access at the cluster level so that the search service account can only reach expected Backstage indices, limiting the blast radius if the authorization bypass is triggered.

Impact

An authenticated Backstage user subject to a DENY policy for search document types could receive search results they were not authorized to view. This affects deployments with permission.enabled: true and an Elasticsearch or OpenSearch search backend.

The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions. Typical impact: unauthorized data access or execution of privileged operations.

CVE-2026-106562 has a CVSS score of 4.3 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (2.1.6, 1.8.7); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-search-backend (< 2.1.6) @backstage/plugin-search-backend-module-elasticsearch (< 1.8.7)

Security releases

@backstage/plugin-search-backend → 2.1.6 (npm) @backstage/plugin-search-backend-module-elasticsearch → 1.8.7 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

  • Upgrade @backstage/plugin-search-backend to 2.1.6
  • Upgrade @backstage/plugin-search-backend-module-elasticsearch to 1.8.7

Frequently Asked Questions

  1. What is CVE-2026-106562? CVE-2026-106562 is a medium-severity incorrect authorization vulnerability in @backstage/plugin-search-backend (npm), affecting versions < 2.1.6. It is fixed in 2.1.6, 1.8.7. The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions.
  2. How severe is CVE-2026-106562? CVE-2026-106562 has a CVSS score of 4.3 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-106562?
    • @backstage/plugin-search-backend (npm) (versions < 2.1.6)
    • @backstage/plugin-search-backend-module-elasticsearch (npm) (versions < 1.8.7)
  4. Is there a fix for CVE-2026-106562? Yes. CVE-2026-106562 is fixed in 2.1.6, 1.8.7. Upgrade to this version or later.
  5. Is CVE-2026-106562 exploitable, and should I be worried? Whether CVE-2026-106562 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106562 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106562?
    • Upgrade @backstage/plugin-search-backend to 2.1.6 or later
    • Upgrade @backstage/plugin-search-backend-module-elasticsearch to 1.8.7 or later

Stop the waste.
Protect your environment with Kodem.