CVE-2026-107385

CVE-2026-107385 is a high-severity SQL injection vulnerability in mariadb (npm), affecting versions < 3.2.5. It is fixed in 3.2.5, 3.3.4, 3.4.7, 3.5.4.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

MariaDB Connector/Node.js: SQL injection in the text protocol when the session uses NOBACKSLASHESCAPES

Description

When escaping string and binary parameters for the text protocol, the connector always escaped the quote character with a backslash, without ever consulting the session's NO_BACKSLASH_ESCAPES SQL mode. The server status flag was declared (STATUS_NO_BACKSLASH_ESCAPES) but never read.

Under a server or session running with NO_BACKSLASH_ESCAPES, the backslash is an ordinary character and the quote must be escaped by doubling it. The escaped value produced by the connector therefore closed the string literal, and a value passed through a placeholder was interpreted as SQL.

All text-protocol escaping entry points were affected, including Connection.escape().

Resolution

The escaping routines now branch on the session status flag, doubling the quote and leaving the backslash untouched when NO_BACKSLASH_ESCAPES is set

Workarounds

Use execute() or batch(), or do not enable NO_BACKSLASH_ESCAPES, until upgraded.

Credit

Reported by fg0x0.

Impact

An attacker able to influence any value the application passes as a query parameter could execute arbitrary SQL with the privileges of the application's database user: read, modify or delete any data reachable by that connection.

Exposure requires a deployment where NO_BACKSLASH_ESCAPES is enabled, server-wide, through the connector's sessionVariables / initSql options, or by an application-issued SET sql_mode. It is not implied by the ANSI, ORACLE or TRADITIONAL compound modes on MariaDB 11.4, so it has to be set deliberately. Where it is enabled, no unusual application code is needed: the standard placeholder API is the injection point.

execute() and batch() are not affected: the binary prepared-statement and bulk protocols send parameter values out of band.

Untrusted input alters a database query, allowing the attacker to read or modify data the query was not intended to access. Typical impact: data disclosure or modification.

CVE-2026-107385 has a CVSS score of 7.4 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.2.5, 3.3.4, 3.4.7, 3.5.4); upgrading removes the vulnerable code path.

Affected versions

mariadb (< 3.2.5) mariadb (>= 3.3.0, < 3.3.4) mariadb (>= 3.4.0, < 3.4.7) mariadb (>= 3.5.0-rc.0, < 3.5.4)

Security releases

mariadb → 3.2.5 (npm) mariadb → 3.3.4 (npm) mariadb → 3.4.7 (npm) mariadb → 3.5.4 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

mariadb to 3.2.5 or later; mariadb to 3.3.4 or later; mariadb to 3.4.7 or later; mariadb to 3.5.4 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-107385? CVE-2026-107385 is a high-severity SQL injection vulnerability in mariadb (npm), affecting versions < 3.2.5. It is fixed in 3.2.5, 3.3.4, 3.4.7, 3.5.4. Untrusted input alters a database query, allowing the attacker to read or modify data the query was not intended to access.
  2. How severe is CVE-2026-107385? CVE-2026-107385 has a CVSS score of 7.4 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of mariadb are affected by CVE-2026-107385? mariadb (npm) versions < 3.2.5 is affected.
  4. Is there a fix for CVE-2026-107385? Yes. CVE-2026-107385 is fixed in 3.2.5, 3.3.4, 3.4.7, 3.5.4. Upgrade to this version or later.
  5. Is CVE-2026-107385 exploitable, and should I be worried? Whether CVE-2026-107385 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-107385 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-107385?
    • Upgrade mariadb to 3.2.5 or later
    • Upgrade mariadb to 3.3.4 or later
    • Upgrade mariadb to 3.4.7 or later
    • Upgrade mariadb to 3.5.4 or later

Other vulnerabilities in mariadb

Stop the waste.
Protect your environment with Kodem.