CVE-2026-107722

CVE-2026-107722 is a critical-severity security vulnerability in fast-jwt (npm), affecting versions >= 6.2.0, <= 6.2.4. It is fixed in 6.3.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

fast-jwt: Incomplete patch of CVE-2026-34950: Non-whitespace key-prefix re-enables RSA→HS256 algorithm confusion

Impact

  1. Authentication bypass, attacker forges arbitrary JWT claims (admin, tenant-id, user-id) accepted by any server using fast-jwt 6.2.x without an algorithms allowlist AND loading its verification key from a source that may contain non-whitespace prefix bytes.
  2. Severity-parity with CVE-2026-34950, attack chain, prerequisites, exploitation ease, and impact are identical; only the trigger byte differs. The fix addressed one trigger (whitespace) rather than the class (any surrounding content before -----BEGIN).
  3. Broad fast-jwt deployment, default JWT backend of @fastify/jwt; used by many Fastify-based Node.js APIs.

CVE-2026-107722 has a CVSS score of 9.8 (Critical). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (6.3.0); upgrading removes the vulnerable code path.

Affected versions

fast-jwt (>= 6.2.0, <= 6.2.4)

Security releases

fast-jwt → 6.3.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Option A (minimal), locate the PEM block rather than anchoring on position 0:

const pemStart = trimmedKey.indexOf('-----BEGIN')
if (pemStart !== -1 && publicKeyPemMatcher.test(trimmedKey.slice(pemStart))) { ... }

Option B (strict, recommended), require the key to be exactly a PEM block:

const pemMatch = /-----BEGIN (RSA )?PUBLIC KEY-----[\s\S]+?-----END \1?PUBLIC KEY-----/.exec(trimmedKey)
if (pemMatch && pemMatch[0].trim() === trimmedKey.trim()) { /* valid PEM, no surrounding content */ }

Option C (defense-in-depth, regardless of A/B), on the HMAC fallback path, reject any key that contains PEM markers:

if (rawKey.includes('-----BEGIN') || rawKey.includes('-----END')) {
    throw new Error('Key appears to be a PEM-encoded asymmetric key but did not match expected format; refusing HMAC fallback')
}

Frequently Asked Questions

  1. What is CVE-2026-107722? CVE-2026-107722 is a critical-severity security vulnerability in fast-jwt (npm), affecting versions >= 6.2.0, <= 6.2.4. It is fixed in 6.3.0.
  2. How severe is CVE-2026-107722? CVE-2026-107722 has a CVSS score of 9.8 (Critical). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of fast-jwt are affected by CVE-2026-107722? fast-jwt (npm) versions >= 6.2.0, <= 6.2.4 is affected.
  4. Is there a fix for CVE-2026-107722? Yes. CVE-2026-107722 is fixed in 6.3.0. Upgrade to this version or later.
  5. Is CVE-2026-107722 exploitable, and should I be worried? Whether CVE-2026-107722 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-107722 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-107722? Upgrade fast-jwt to 6.3.0 or later.

Other vulnerabilities in fast-jwt

Stop the waste.
Protect your environment with Kodem.