CVE-2026-109383

CVE-2026-109383 is a high-severity security vulnerability in undici (npm), affecting versions >= 4.0.0, < 6.29.1. It is fixed in 6.29.1, 7.30.1, 8.12.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent

Workarounds

Pass the TLS options through connect instead of tls. For proxied EnvHttpProxyAgent destinations, use requestTls / proxyTls.

Impact

undici's Agent passes its constructor options through a JSON-based deep clone (JSON.parse(JSON.stringify(...))) before forwarding them to each per-origin Pool. JSON cannot represent functions, so a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted when the request is made through Agent. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this is the path most applications use. EnvHttpProxyAgent is also affected on its direct and NO_PROXY routes, which delegate to an internal Agent.

Only applications that pass a function-valued tls option (such as a custom checkServerIdentity for certificate or public-key pinning) are affected. Passing the same options through connect is not affected. This is the Agent counterpart of the BalancedPool certificate validation bypass fixed in CVE-2026-84961.

CVE-2026-109383 has a CVSS score of 7.4 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (6.29.1, 7.30.1, 8.12.2); upgrading removes the vulnerable code path.

Affected versions

undici (>= 4.0.0, < 6.29.1) undici (>= 7.0.0, < 7.30.1) undici (>= 8.0.0, < 8.12.2)

Security releases

undici → 6.29.1 (npm) undici → 7.30.1 (npm) undici → 8.12.2 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade to undici 6.29.1, 7.30.1, or 8.12.2. Agent now preserves the tls option outside the JSON clone, so custom TLS verification callbacks are forwarded to each origin unchanged.

Frequently Asked Questions

  1. What is CVE-2026-109383? CVE-2026-109383 is a high-severity security vulnerability in undici (npm), affecting versions >= 4.0.0, < 6.29.1. It is fixed in 6.29.1, 7.30.1, 8.12.2.
  2. How severe is CVE-2026-109383? CVE-2026-109383 has a CVSS score of 7.4 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of undici are affected by CVE-2026-109383? undici (npm) versions >= 4.0.0, < 6.29.1 is affected.
  4. Is there a fix for CVE-2026-109383? Yes. CVE-2026-109383 is fixed in 6.29.1, 7.30.1, 8.12.2. Upgrade to this version or later.
  5. Is CVE-2026-109383 exploitable, and should I be worried? Whether CVE-2026-109383 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-109383 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-109383?
    • Upgrade undici to 6.29.1 or later
    • Upgrade undici to 7.30.1 or later
    • Upgrade undici to 8.12.2 or later

Other vulnerabilities in undici

Stop the waste.
Protect your environment with Kodem.