CVE-2026-110180

CVE-2026-110180 is a medium-severity improper input validation vulnerability in fast-uri (npm), affecting versions >= 2.4.2, < 2.4.8. It is fixed in 2.4.8, 3.1.9, 4.2.3.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

Workarounds

Reject URIs whose authority contains more than one @, or contains TAB, CR, or LF, before calling fast-uri. Alternatively, treat any non-empty parse(x).error as fatal, and compare hosts only from the same parse() result.

Impact

fast-uri versions >= 2.4.2, <= 2.4.7, >= 3.1.3, <= 3.1.8, and >= 4.0.1, <= 4.2.2 can silently rewrite the host of an HTTP-family URL (http, https, ws, wss, or any scheme with domainHost: true). For those schemes canonicalizeHost() passes the parsed host to the WHATWG URL parser and adopts its .hostname without checking that the parser read the whole input as a host. RFC 3986 permits @ inside the host group and the WHATWG parser strips TAB, LF, and CR, so the authority fast-uri reports is rewritten by that second parser with no error set: data before an @ is dropped and whitespace is removed.

For example, fast-uri parses http://a@[email protected]/ to host evil.example (dropping the b segment), and a host containing a raw TAB, CR, or LF has those characters stripped. equal() then treats a whitespace-smuggled host as the same as the clean one, and resolve() rewrites the authority the same way.

Applications that use fast-uri to enforce host-based policy (denylists, loopback filtering, redirect validation, outbound proxy routing) on one representation, such as the raw input, see a policy/use desync: the canonical host fast-uri returns differs from what was checked, and traffic can be steered to an unintended destination.

The application does not adequately validate input before processing it, allowing unexpected values to reach sensitive code paths. Typical impact: varies by context: data corruption, logic bypass, or denial of service.

CVE-2026-110180 has a CVSS score of 4.8 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (2.4.8, 3.1.9, 4.2.3); upgrading removes the vulnerable code path.

Affected versions

fast-uri (>= 2.4.2, < 2.4.8) fast-uri (>= 3.1.3, < 3.1.9) fast-uri (>= 4.0.1, < 4.2.3)

Security releases

fast-uri → 2.4.8 (npm) fast-uri → 3.1.9 (npm) fast-uri → 4.2.3 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade to fast-uri 2.4.8, 3.1.9, or 4.2.3.

Frequently Asked Questions

  1. What is CVE-2026-110180? CVE-2026-110180 is a medium-severity improper input validation vulnerability in fast-uri (npm), affecting versions >= 2.4.2, < 2.4.8. It is fixed in 2.4.8, 3.1.9, 4.2.3. The application does not adequately validate input before processing it, allowing unexpected values to reach sensitive code paths.
  2. How severe is CVE-2026-110180? CVE-2026-110180 has a CVSS score of 4.8 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of fast-uri are affected by CVE-2026-110180? fast-uri (npm) versions >= 2.4.2, < 2.4.8 is affected.
  4. Is there a fix for CVE-2026-110180? Yes. CVE-2026-110180 is fixed in 2.4.8, 3.1.9, 4.2.3. Upgrade to this version or later.
  5. Is CVE-2026-110180 exploitable, and should I be worried? Whether CVE-2026-110180 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-110180 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-110180?
    • Upgrade fast-uri to 2.4.8 or later
    • Upgrade fast-uri to 3.1.9 or later
    • Upgrade fast-uri to 4.2.3 or later

Other vulnerabilities in fast-uri

Stop the waste.
Protect your environment with Kodem.