Summary
vLLM: Request-controlled mmprocessorkwargs.code_revision allows remote code execution
An untrusted multimodal request can set mm_processor_kwargs.code_revision. When vLLM serves a model whose Hugging Face processor uses dynamic auto_map code and the operator enabled --trust-remote-code, this request value reaches AutoProcessor.from_pretrained and selects the Python revision imported by Transformers.
This lets a client replace the operator-reviewed processor module with code from another revision of the same model repository. The operator-selected model/data revision remains pinned; only the executed processor code changes.
Importing a Python module is arbitrary code execution in the vLLM API/renderer process. The PoC below demonstrates this with an import-time filesystem write. It is fully offline and does not require a GPU, model weights, or changes to a real Hub repository.
Affected snapshot
- Repository:
vllm-project/vllm - Verified commit:
570735520942b6428ae98f1eb442c6d88adae55e - Verified with Transformers 5.15.0 and 5.16.1
- Affected release range has not been bisected
Affected configuration
The vulnerable path exists when all of the following are true:
- The served model's processor uses dynamic
auto_map.AutoProcessorcode. - The operator enabled
trust_remote_code. - The server can fetch the request-selected revision, or it is already cached.
- The attacker can create or otherwise control a revision in the served model repository. An example is a Hugging Face community pull-request ref when that repository permits them.
- A multimodal request reaches the processor path.
The default trust_remote_code=False configuration is not affected.
Attack surface
mm_processor_kwargs is accepted directly by public request models:
/tokenize is particularly relevant because vLLM's authentication middleware guards only /v1, /v2, /inference, and /cohere prefixes:
Consequently, /tokenize remains unauthenticated even when --api-key is configured, unless an external proxy protects it. The vLLM Security Guide documents /tokenize as an unprotected endpoint.
Root cause
The request value follows this path:
OnlineRenderer.preprocess_chatplaces requestmm_processor_kwargsin prompt extras.- Multimodal rendering forwards those kwargs into processor construction through
MMProcessorInputsand_process_multimodal_async. MultiModalConfig.merge_mm_processor_kwargsoverlays inference values on startup values, so the request wins.cached_get_processor_without_dynamic_kwargsfilters only recognized processor-call keys.code_revisionis retained as a processor-construction kwarg.cached_processor_from_configpinsrevisionandtrust_remote_code, but forwards the remaining kwargs without reservingcode_revision.get_processorcallsAutoProcessor.from_pretrained(..., revision=revision, trust_remote_code=trust_remote_code, **kwargs).- Transformers
AutoProcessor.from_pretrainedusescode_revisionto retrieve and import the dynamic module throughget_class_from_dynamic_module, then removes it before loading processor data. This is why code comes from the attacker revision while configuration/data remain operator-pinned.
Request-time processor arguments are not separated from processor-construction arguments, and code_revision is not reserved.
Suggested remediation
- Separate processor-construction arguments from untrusted processor-call arguments. An allowlist of supported request-time preprocessing controls is safest.
- Reject
code_revisionand other loader/source controls in requestmm_processor_kwargs, and passmodel_config.code_revisionexplicitly as the only permitted processor-code revision. - Add a regression test proving a request cannot change the loaded module revision while operator pins remain effective.
- Protect
/tokenizewith the configured authentication policy as defense in depth.
Expected safe behavior is either a 4xx response for reserved request keys or silently ignoring them before processor construction. Rejection is preferable because it makes attempted misuse visible.
A patch for this was merged here: https://github.com/vllm-project/vllm/pull/58830
Impact
Untrusted input is evaluated as executable code within the application's runtime environment. Typical impact: arbitrary code execution within the application's privilege context.
CVE-2026-114053 has a CVSS score of 8.1 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.31.0); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.
Frequently Asked Questions
- What is CVE-2026-114053? CVE-2026-114053 is a high-severity code injection vulnerability in vllm (pip), affecting versions >= 0.7.3, < 0.31.0. It is fixed in 0.31.0. Untrusted input is evaluated as executable code within the application's runtime environment.
- How severe is CVE-2026-114053? CVE-2026-114053 has a CVSS score of 8.1 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of vllm are affected by CVE-2026-114053? vllm (pip) versions >= 0.7.3, < 0.31.0 is affected.
- Is there a fix for CVE-2026-114053? Yes. CVE-2026-114053 is fixed in 0.31.0. Upgrade to this version or later.
- Is CVE-2026-114053 exploitable, and should I be worried? Whether CVE-2026-114053 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-114053 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-114053? Upgrade
vllmto 0.31.0 or later.