CVE-2026-114139

CVE-2026-114139 is a critical-severity security vulnerability in @sentry/nextjs (npm), affecting versions >= 9.36.0, < 9.47.2. It is fixed in 9.47.2, 10.75.2, 11.0.0-rc.1.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Sentry-Javascript: Middleware Bypass when using Tunnel route

Workarounds

  • Set tunnelRoute to a path no route of yours can resolve under, or remove the option.
  • Build with Turbopack (default for next build from Next.js 16).
  • Enforce authorization in the route, layout or data-access path as well as in middleware.

Impact

The tunnelRoute option makes the SDK send browser events to a path on your own Next.js server (for example /monitoring), where a rewrite forwards them to Sentry to prevent ad blockers from blocking them. To keep those envelope requests from being rejected by your middleware, the SDK skips middleware for them.

The middleware skip was wider than the rewrite. The rewrite only serves requests to the tunnel path itself with the o and p parameters set. The skip applied to anything under the tunnel path. Requests in that gap go to your application instead of Sentry, and your middleware never runs on them.

Skipping middleware does not grant the request any privileges. Routes that check the session server-side are still protected.

You are affected only if all of the following are true:

  1. tunnelRoute is set (a string path or true),
  2. your app is built with webpack (Turbopack builds are not affected),
  3. some route of your application resolves under the tunnel path. That could be a direct collision (/monitoring/foo with tunnelRoute: '/monitoring') or a dynamic segment at the route root (app/[locale]/…), which matches any first path segment, and
  4. your middleware is the only place that enforces authorization for those routes.

Sentry's own services, and the data in your Sentry organization, are not affected.

Affected versions

@sentry/nextjs (>= 9.36.0, < 9.47.2) @sentry/nextjs (>= 10.0.0-alpha.0, < 10.75.2) @sentry/nextjs (>= 11.0.0-alpha.0, < 11.0.0-rc.1)

Security releases

@sentry/nextjs → 9.47.2 (npm) @sentry/nextjs → 10.75.2 (npm) @sentry/nextjs → 11.0.0-rc.1 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in 9.47.2, 10.75.2 and 11.0.0-rc.1. The skip now matches only the requests the tunnel rewrite actually serves. No configuration change is needed.

Frequently Asked Questions

  1. What is CVE-2026-114139? CVE-2026-114139 is a critical-severity security vulnerability in @sentry/nextjs (npm), affecting versions >= 9.36.0, < 9.47.2. It is fixed in 9.47.2, 10.75.2, 11.0.0-rc.1.
  2. Which versions of @sentry/nextjs are affected by CVE-2026-114139? @sentry/nextjs (npm) versions >= 9.36.0, < 9.47.2 is affected.
  3. Is there a fix for CVE-2026-114139? Yes. CVE-2026-114139 is fixed in 9.47.2, 10.75.2, 11.0.0-rc.1. Upgrade to this version or later.
  4. Is CVE-2026-114139 exploitable, and should I be worried? Whether CVE-2026-114139 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-114139 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-114139?
    • Upgrade @sentry/nextjs to 9.47.2 or later
    • Upgrade @sentry/nextjs to 10.75.2 or later
    • Upgrade @sentry/nextjs to 11.0.0-rc.1 or later

Other vulnerabilities in @sentry/nextjs

Stop the waste.
Protect your environment with Kodem.