Summary
LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key
An authenticated user with internal_user privileges can escalate to proxy_admin and achieve remote code execution. The proxy uses one encryption key for two purposes: sealing secrets at rest and minting session tokens. An attacker exploits this by requesting a new API key with a crafted metadata field containing a forged admin credential as the "secret" value. The proxy encrypts and returns this payload. When this value is then presented as a bearer token, the proxy decrypts it, trusts the forged admin identity, and grants full administrative access, including the ability to execute arbitrary commands via the MCP stdio endpoint.
Affected versions
Versions later than 1.91.0 are exploitable in the default configuration. Versions 1.87.0 through 1.90.x are exploitable only if EXPERIMENTAL_UI_LOGIN=true was explicitly set.
Mitigation
Upgrade to a patched version as soon as possible.
If you cannot upgrade immediately, set EXPERIMENTAL_UI_LOGIN=false. This disables the vulnerable authentication path but also breaks CLI SSO and Claude Code gateway login.
Impact
An internal user can escalate to proxy admin and execute arbitrary commands on the host.
Discovery Credit: Hoa X. Nguyen (OPSWAT Unit 515)
The application assigns, modifies, tracks, or checks privileges incorrectly, allowing a user to gain elevated access. Typical impact: privilege escalation beyond the intended level.
CVE-2026-114612 has a CVSS score of 9.9 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.100.4, 1.101.3, 1.102.2, 1.103.1, 1.104.0rc2); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
litellm to 1.100.4 or later; litellm to 1.101.3 or later; litellm to 1.102.2 or later; litellm to 1.103.1 or later; litellm to 1.104.0rc2 or later
Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.
Frequently Asked Questions
- What is CVE-2026-114612? CVE-2026-114612 is a high-severity improper privilege management vulnerability in litellm (pip), affecting versions >= 1.91.0, < 1.100.4. It is fixed in 1.100.4, 1.101.3, 1.102.2, 1.103.1, 1.104.0rc2. The application assigns, modifies, tracks, or checks privileges incorrectly, allowing a user to gain elevated access.
- How severe is CVE-2026-114612? CVE-2026-114612 has a CVSS score of 9.9 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of litellm are affected by CVE-2026-114612? litellm (pip) versions >= 1.91.0, < 1.100.4 is affected.
- Is there a fix for CVE-2026-114612? Yes. CVE-2026-114612 is fixed in 1.100.4, 1.101.3, 1.102.2, 1.103.1, 1.104.0rc2. Upgrade to this version or later.
- Is CVE-2026-114612 exploitable, and should I be worried? Whether CVE-2026-114612 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-114612 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-114612?
- Upgrade
litellmto 1.100.4 or later - Upgrade
litellmto 1.101.3 or later - Upgrade
litellmto 1.102.2 or later - Upgrade
litellmto 1.103.1 or later - Upgrade
litellmto 1.104.0rc2 or later
- Upgrade