CVE-2026-115885

CVE-2026-115885 is a medium-severity security vulnerability in langgraph-cli (pip), affecting versions >= 0.4.15, <= 0.4.31. It is fixed in 0.4.32.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

LangGraph CLI prints the registry push token in langgraph deploy --verbose output

langgraph deploy --verbose printed the temporary registry push token that the CLI uses to log Docker in to the deployment's image registry. Anyone who could read that output, for example in CI logs, could use the token until it expired.

Details

When Docker is available, langgraph deploy builds the image locally, requests a push token from LangSmith, and runs docker login --password-stdin with the token on stdin. The CLI's subprocess helper printed each command's stdin when verbose output was on, and the login step inherited --verbose, so the token was printed right after the docker login command line.

langgraph-cli 0.4.15 through 0.4.31 are affected. Starting with 0.4.32, the login step runs without verbose output. Deploys run without --verbose, and deploys that build the image remotely, never printed the token.

Impact

You may be affected if you ran langgraph deploy --verbose with an affected version and the output was kept or shared, for example in CI logs or terminal recordings. The token is short-lived (at most 12 hours) and limited to that deployment's image repository. Someone holding it before it expired could pull the deployment's images and push new images to that repository. Deployments reference their image by digest, so a pushed image does not run unless the deployment is updated to use it, which requires a LangSmith API key with access to the deployment.

CVE-2026-115885 has a CVSS score of 5.4 (Medium). The vector is network-reachable, low privileges required, and user interaction required. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.4.32); upgrading removes the vulnerable code path.

Affected versions

langgraph-cli (>= 0.4.15, <= 0.4.31)

Security releases

langgraph-cli → 0.4.32 (pip)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade to langgraph-cli 0.4.32 or later. 0.4.37 also stops --verbose from printing the input of any command the CLI runs. Tokens printed more than 12 hours ago have expired.

Frequently Asked Questions

  1. What is CVE-2026-115885? CVE-2026-115885 is a medium-severity security vulnerability in langgraph-cli (pip), affecting versions >= 0.4.15, <= 0.4.31. It is fixed in 0.4.32.
  2. How severe is CVE-2026-115885? CVE-2026-115885 has a CVSS score of 5.4 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of langgraph-cli are affected by CVE-2026-115885? langgraph-cli (pip) versions >= 0.4.15, <= 0.4.31 is affected.
  4. Is there a fix for CVE-2026-115885? Yes. CVE-2026-115885 is fixed in 0.4.32. Upgrade to this version or later.
  5. Is CVE-2026-115885 exploitable, and should I be worried? Whether CVE-2026-115885 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-115885 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-115885? Upgrade langgraph-cli to 0.4.32 or later.

Stop the waste.
Protect your environment with Kodem.