CVE-2026-115923

CVE-2026-115923 is a medium-severity path traversal vulnerability in @backstage/plugin-catalog-backend (npm), affecting versions < 3.9.2. It is fixed in 3.9.2, 4.0.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage catalog rules can be bypassed for URL locations using encoded path segments

@backstage/plugin-catalog-backend matches URL-type locations against catalog.rules location patterns using the raw URL string submitted by the user, while URL readers resolve that same string in canonical form when fetching the location's content. A URL can therefore be crafted so that it appears to belong to a trusted location scope during rule evaluation, but is fetched from a different scope.

Details

When a deployment restricts catalog kinds to trusted URL prefixes using catalog.rules location patterns, DefaultCatalogRulesEnforcer applies glob matching directly to the raw location.target string. The URL readers used for ingestion resolve the same target in canonical form, including normalizing percent-encoded dot segments. A registered location such as https://<host>/trusted/%2e%2e/attacker/repo/blob/main/catalog-info.yaml matches a https://<host>/trusted/** pattern as a raw string, but resolves to and is fetched from https://<host>/attacker/repo/... when its content is read.

An authenticated user with permission to register catalog locations (catalog.location.create) can use this to have an entity from an untrusted source admitted as if it originated from a trusted location scope.

Workarounds

No complete workaround is available for deployments that rely on URL location patterns to restrict catalog kinds. Restricting location registration permissions reduces exposure.

Impact

The crossed boundary is the operator-configured catalog ingestion policy: entity content from outside the trusted location scope is ingested as if it were within it. Downstream consequences depend on deployment configuration, for example actions taken with integration credentials by processors or scaffolder when acting on the ingested entity. The assessment of this report found no basis for impact claims beyond the ingestion policy boundary itself.

Input manipulates file paths to reach files outside the intended directory, such as configuration or credential files. Typical impact: unauthorized file read or write outside the intended directory.

CVE-2026-115923 has a CVSS score of 6.5 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.9.2, 4.0.2); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-catalog-backend (< 3.9.2) @backstage/plugin-catalog-backend (>= 4.0.0, < 4.0.2)

Security releases

@backstage/plugin-catalog-backend → 3.9.2 (npm) @backstage/plugin-catalog-backend → 4.0.2 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

This is fixed in @backstage/plugin-catalog-backend 3.9.2 (Backstage release 1.54.10) and 4.0.2 (Backstage release 1.56.1). Version 4.0.1 as published is not fixed.

Frequently Asked Questions

  1. What is CVE-2026-115923? CVE-2026-115923 is a medium-severity path traversal vulnerability in @backstage/plugin-catalog-backend (npm), affecting versions < 3.9.2. It is fixed in 3.9.2, 4.0.2. Input manipulates file paths to reach files outside the intended directory, such as configuration or credential files.
  2. How severe is CVE-2026-115923? CVE-2026-115923 has a CVSS score of 6.5 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @backstage/plugin-catalog-backend are affected by CVE-2026-115923? @backstage/plugin-catalog-backend (npm) versions < 3.9.2 is affected.
  4. Is there a fix for CVE-2026-115923? Yes. CVE-2026-115923 is fixed in 3.9.2, 4.0.2. Upgrade to this version or later.
  5. Is CVE-2026-115923 exploitable, and should I be worried? Whether CVE-2026-115923 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-115923 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-115923?
    • Upgrade @backstage/plugin-catalog-backend to 3.9.2 or later
    • Upgrade @backstage/plugin-catalog-backend to 4.0.2 or later

Other vulnerabilities in @backstage/plugin-catalog-backend

Stop the waste.
Protect your environment with Kodem.