CVE-2026-116675

CVE-2026-116675 is a high-severity cross-site scripting (XSS) vulnerability in tinymce (npm), affecting versions >= 8.5.1, < 8.9.3. It is fixed in 8.9.3, 7.9.4.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin data-mce-object serialization

Workarounds

No official workaround available.

Fix

To avoid this vulnerability:

Upgrade to TinyMCE 8.9.3 or higher.
Upgrade to TinyMCE 7.9.4 or higher.

Acknowledgements

Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.

Impact

Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

Affected versions

tinymce (>= 8.5.1, < 8.9.3) TinyMCE (>= 8.5.1, < 8.9.3) tinymce/tinymce (>= 8.5.1, < 8.9.3) tinymce (= 7.9.3) TinyMCE (= 7.9.3) tinymce/tinymce (= 7.9.3)

Security releases

tinymce → 8.9.3 (npm) TinyMCE → 8.9.3 (nuget) tinymce/tinymce → 8.9.3 (composer) tinymce → 7.9.4 (npm) TinyMCE → 7.9.4 (nuget) tinymce/tinymce → 7.9.4 (composer)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.

Frequently Asked Questions

  1. What is CVE-2026-116675? CVE-2026-116675 is a high-severity cross-site scripting (XSS) vulnerability in tinymce (npm), affecting versions >= 8.5.1, < 8.9.3. It is fixed in 8.9.3, 7.9.4. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. Which packages are affected by CVE-2026-116675?
    • tinymce (npm) (versions >= 8.5.1, < 8.9.3)
    • TinyMCE (nuget) (versions >= 8.5.1, < 8.9.3)
    • tinymce/tinymce (composer) (versions >= 8.5.1, < 8.9.3)
  3. Is there a fix for CVE-2026-116675? Yes. CVE-2026-116675 is fixed in 8.9.3, 7.9.4. Upgrade to this version or later.
  4. Is CVE-2026-116675 exploitable, and should I be worried? Whether CVE-2026-116675 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-116675 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-116675?
    • Upgrade tinymce to 8.9.3 or later
    • Upgrade TinyMCE to 8.9.3 or later
    • Upgrade tinymce/tinymce to 8.9.3 or later
    • Upgrade tinymce to 7.9.4 or later
    • Upgrade TinyMCE to 7.9.4 or later
    • Upgrade tinymce/tinymce to 7.9.4 or later

Other vulnerabilities in tinymce

Stop the waste.
Protect your environment with Kodem.