Summary
Neko: Authorization bypass in legacy WebRTC input handling
Workarounds
Users who cannot immediately upgrade can mitigate the issue by one of the following:
- Disable legacy mode if it is not required.
- Disable implicit hosting (
session.implicit_hosting=false). - Restrict access to trusted authenticated users.
Credits
Thanks to @KasperBuilds for responsibly disclosing this vulnerability and reaching out directly. This contribution helped strengthen the project, and the whole community benefits from it.
Impact
When legacy mode is enabled and session.implicit_hosting is enabled, the legacy WebRTC data channel incorrectly authorizes input events due to a logic error in LegacyIsHost().
As a result, an authenticated room member may be able to send mouse and keyboard input through the legacy WebRTC control channel even when controls are locked or the member would otherwise not be authorized through the modern control API.
The issue affects only the legacy WebRTC input path. The modern HTTP/WebSocket control path correctly enforces authorization checks and is not affected.
To exploit this issue, an attacker must:
- Be authenticated as a room member.
- Successfully establish a WebRTC connection.
- Access a deployment using the legacy WebRTC input handler.
No unauthenticated access or privilege escalation outside the application is possible.
The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions. Typical impact: unauthorized data access or execution of privileged operations.
CVE-2026-116679 has a CVSS score of 5.4 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.0.0-20260805142851-395ca1a6f62b); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
The issue has been fixed in v3.1.5 by correcting the authorization logic in the legacy WebRTC handler.
Frequently Asked Questions
- What is CVE-2026-116679? CVE-2026-116679 is a medium-severity incorrect authorization vulnerability in github.com/m1k1o/neko/server (go), affecting versions >= 0.0.0-20250401220545-fe94c999c6af, < 0.0.0-20260805142851-395ca1a6f62b. It is fixed in 0.0.0-20260805142851-395ca1a6f62b. The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions.
- How severe is CVE-2026-116679? CVE-2026-116679 has a CVSS score of 5.4 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of github.com/m1k1o/neko/server are affected by CVE-2026-116679? github.com/m1k1o/neko/server (go) versions >= 0.0.0-20250401220545-fe94c999c6af, < 0.0.0-20260805142851-395ca1a6f62b is affected.
- Is there a fix for CVE-2026-116679? Yes. CVE-2026-116679 is fixed in 0.0.0-20260805142851-395ca1a6f62b. Upgrade to this version or later.
- Is CVE-2026-116679 exploitable, and should I be worried? Whether CVE-2026-116679 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-116679 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-116679? Upgrade
github.com/m1k1o/neko/serverto 0.0.0-20260805142851-395ca1a6f62b or later.