CVE-2026-116683

CVE-2026-116683 is a high-severity security vulnerability in github.com/ctfer-io/terraform-provider-ctfd (go), affecting versions >= 0.1.5, <= 1.1.0. It is fixed in 2.8.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

CTFer.io's CTFd Terraform Provider allows a local or remote attacker to read team passwords in state as non sensitive values

Workarounds

No workaround exist, yet CTFer.io recommends you keep your state in safe environments with a limited set of users who can access it as a good practice to avoid exploitation of this vulnerability.

Impact

CTFer.io's CTFd Terraform Provider stores ctfd_team.password as non-sensitive values (CWE-522). A local or remote attacker, who can have access to the Terraform state, can read team passwords without the need for the state password for decryption.

Affected versions

github.com/ctfer-io/terraform-provider-ctfd (>= 0.1.5, <= 1.1.0) github.com/ctfer-io/terraform-provider-ctfd/v2 (< 2.8.2)

Security releases

github.com/ctfer-io/terraform-provider-ctfd/v2 → 2.8.2 (go)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Patched in v2.8.2.

Frequently Asked Questions

  1. What is CVE-2026-116683? CVE-2026-116683 is a high-severity security vulnerability in github.com/ctfer-io/terraform-provider-ctfd (go), affecting versions >= 0.1.5, <= 1.1.0. It is fixed in 2.8.2.
  2. Which packages are affected by CVE-2026-116683?
    • github.com/ctfer-io/terraform-provider-ctfd (go) (versions >= 0.1.5, <= 1.1.0)
    • github.com/ctfer-io/terraform-provider-ctfd/v2 (go) (versions < 2.8.2)
  3. Is there a fix for CVE-2026-116683? Yes. CVE-2026-116683 is fixed in 2.8.2. Upgrade to this version or later.
  4. Is CVE-2026-116683 exploitable, and should I be worried? Whether CVE-2026-116683 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-116683 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-116683? Upgrade github.com/ctfer-io/terraform-provider-ctfd/v2 to 2.8.2 or later.

Stop the waste.
Protect your environment with Kodem.