CVE-2026-118246

CVE-2026-118246 is a high-severity cross-site scripting (XSS) vulnerability in highcharts (npm), affecting versions >= 10.0.0, < 11.4.9. It is fixed in 11.4.9, 12.6.1, 13.1.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Highcharts Core: breadcrumbs.style keys become SVG event-handler attributes

Workarounds

Verified against published bundles on 10.0.0, 11.4.8, 12.3.0 and 13.0.2.

Load immediately after Highcharts, before any chart is created:

// Workaround fix for all affected Highcharts versions: 10.0.0-13.0.2
((H)=>{const S=H.SVGElement.prototype,D=S._defaultSetter;S._defaultSetter=function _defaultSetter(v,k,e){/^on/i.test(k)||D.call(this,v,k,e)};})(Highcharts);
// End of the workaround fix

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install [email protected]. If you load Highcharts from the CDN, use the versioned URLs on code.highcharts.com, for example https://code.highcharts.com/13.1.0/highcharts.js. For more on each installation method, see the installation guide.

Impact

The breadcrumbs style option is applied to the breadcrumb button as SVG attributes rather than as CSS, and the attribute names are not filtered. An attacker who controls the chart configuration can supply keys under breadcrumbs.style that name event handlers, and those keys become live handlers on the breadcrumb button, so the attacker's script runs in the origin of the page hosting the chart. The option is reached through drilldown.breadcrumbs, navigation.breadcrumbs and the breadcrumbs option of the treemap, sunburst and treegraph series. Exploitation requires that untrusted data reach the chart configuration and that a user drill down, or traverse into a level of a hierarchical series, so that the breadcrumbs render, and then hover over or activate the breadcrumb button. Charts rendered in styled mode do not apply the option and are not affected. Charts built with Highcharts Stock, Maps and Gantt are included, since those ship from the same package as Core.

Untrusted input is rendered as active markup in a victim's browser, which can run script in their session. Typical impact: session or credential theft, and actions taken as the user.

Affected versions

highcharts (>= 10.0.0, < 11.4.9) highcharts (>= 12.0.0, < 12.6.1) highcharts (>= 13.0.0, <= 13.0.2)

Security releases

highcharts → 11.4.9 (npm) highcharts → 12.6.1 (npm) highcharts → 13.1.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

highcharts to 11.4.9 or later; highcharts to 12.6.1 or later; highcharts to 13.1.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-118246? CVE-2026-118246 is a high-severity cross-site scripting (XSS) vulnerability in highcharts (npm), affecting versions >= 10.0.0, < 11.4.9. It is fixed in 11.4.9, 12.6.1, 13.1.0. Untrusted input is rendered as active markup in a victim's browser, which can run script in their session.
  2. Which versions of highcharts are affected by CVE-2026-118246? highcharts (npm) versions >= 10.0.0, < 11.4.9 is affected.
  3. Is there a fix for CVE-2026-118246? Yes. CVE-2026-118246 is fixed in 11.4.9, 12.6.1, 13.1.0. Upgrade to this version or later.
  4. Is CVE-2026-118246 exploitable, and should I be worried? Whether CVE-2026-118246 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-118246 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-118246?
    • Upgrade highcharts to 11.4.9 or later
    • Upgrade highcharts to 12.6.1 or later
    • Upgrade highcharts to 13.1.0 or later

Other vulnerabilities in highcharts

Stop the waste.
Protect your environment with Kodem.