CVE-2026-119198

CVE-2026-119198 is a medium-severity security vulnerability in @nuxt/vite-builder (npm), affecting versions >= 4.6.0, < 4.6.3. It is fixed in 4.6.3.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Nuxt dev server arbitrary file read through client error reports

A client that can connect to the dev server's HMR socket can send a nuxt:dev:client-error event whose message ends in an absolute file path. The dev server reads that file while building the error report, and its contents are returned in the error overlay, on the dev error channel, and in the report shown in the terminal.

Workarounds

Do not expose the dev server to untrusted networks: keep the default localhost bind, and avoid nuxt dev --host, nuxt dev --tunnel and proxies onto the dev port. If the dev port was reachable from an untrusted network while a vulnerable version was running, treat any file readable by the dev process on that machine as exposed, and rotate credentials such as SSH keys and .env secrets.

Credits

Thanks to @samsulselfut for the report.

Impact

This affects the development server only; production builds contain none of this code. Affected versions are 4.6.0 to 4.6.2.

Reading the file requires TCP access to the dev server, so the default localhost bind limits this to local processes, which can usually read the same files directly. With the dev server exposed to a network (nuxt dev --host, nuxt dev --tunnel, or a proxy onto the dev port), anyone who can reach the port can read any file the dev process can read: SSH keys, .env files, cloud credentials and other files outside the project. The same path is refused by Vite's server.fs allow list over /_nuxt/@fs/; the client error channel bypasses that check.

No user interaction is needed and no browser is involved: a plain WebSocket client is enough, as long as it does not send Sec-Fetch-Site: cross-site. A web page on another origin cannot retrieve the report: the overlay and channel endpoints reject browser requests from other origins.

Nuxt 3 is not affected.

CVE-2026-119198 has a CVSS score of 5.9 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (4.6.3); upgrading removes the vulnerable code path.

Affected versions

@nuxt/vite-builder (>= 4.6.0, < 4.6.3)

Security releases

@nuxt/vite-builder → 4.6.3 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in @nuxt/vite-builder 4.6.3, which nuxt 4.6.3 depends on. A client-reported error is no longer turned into a compile report, and report building for it no longer reads from the filesystem; file content now comes only from the dev server's module graph.

Frequently Asked Questions

  1. What is CVE-2026-119198? CVE-2026-119198 is a medium-severity security vulnerability in @nuxt/vite-builder (npm), affecting versions >= 4.6.0, < 4.6.3. It is fixed in 4.6.3.
  2. How severe is CVE-2026-119198? CVE-2026-119198 has a CVSS score of 5.9 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @nuxt/vite-builder are affected by CVE-2026-119198? @nuxt/vite-builder (npm) versions >= 4.6.0, < 4.6.3 is affected.
  4. Is there a fix for CVE-2026-119198? Yes. CVE-2026-119198 is fixed in 4.6.3. Upgrade to this version or later.
  5. Is CVE-2026-119198 exploitable, and should I be worried? Whether CVE-2026-119198 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-119198 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-119198? Upgrade @nuxt/vite-builder to 4.6.3 or later.

Other vulnerabilities in @nuxt/vite-builder

Stop the waste.
Protect your environment with Kodem.