CVE-2026-119281

CVE-2026-119281 is a medium-severity security vulnerability in org.mariadb.jdbc:mariadb-java-client (maven), affecting versions >= 3.0.0, < 3.3.7. It is fixed in 3.3.7, 3.4.5, 3.5.11.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

MariaDB Connector/J: Server could switch charactersetresults away from UTF-8 without the client noticing

MariaDB Connector/J decodes every result as UTF-8 and guards
character_set_client against a change to another charset, but did not guard
character_set_results, and relied on the server's global
session_track_system_variables list to be told about charset changes at all.

Details

The connector learns about session variable changes through session tracking,
and closes the connection when character_set_client is switched away from UTF-8,
so that its UTF-8 decoding stays correct. Two gaps remained:

  • character_set_results was not guarded: a server could switch it to another
    charset, after which the bytes of every result were decoded as UTF-8 although
    encoded otherwise.
  • the list of tracked variables came from the server's global
    session_track_system_variables: a server configured, or made, not to track
    the character set variables could change them silently.

The fix requests an explicit session tracking list that includes both character
set variables whatever the server's global setting, and closes the connection
when character_set_results is changed to a charset other than utf8, utf8mb3
or utf8mb4, as it already did for character_set_client.

Credit

Reported by fg0x0

Impact

Integrity: a malicious or compromised server, or a MitM, can make the strings an
application reads differ from the bytes the server returned (inappropriate
encoding for the output context), which can defeat application-side validation
or escaping built on those values. Exploitation requires control of the server
side of the connection; no confidentiality or availability impact.

CVE-2026-119281 has a CVSS score of 5.9 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.3.7, 3.4.5, 3.5.11); upgrading removes the vulnerable code path.

Affected versions

org.mariadb.jdbc:mariadb-java-client (>= 3.0.0, < 3.3.7) org.mariadb.jdbc:mariadb-java-client (>= 3.4.0, < 3.4.5) org.mariadb.jdbc:mariadb-java-client (>= 3.5.0, < 3.5.11)

Security releases

org.mariadb.jdbc:mariadb-java-client → 3.3.7 (maven) org.mariadb.jdbc:mariadb-java-client → 3.4.5 (maven) org.mariadb.jdbc:mariadb-java-client → 3.5.11 (maven)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

org.mariadb.jdbc:mariadb-java-client to 3.3.7 or later; org.mariadb.jdbc:mariadb-java-client to 3.4.5 or later; org.mariadb.jdbc:mariadb-java-client to 3.5.11 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-119281? CVE-2026-119281 is a medium-severity security vulnerability in org.mariadb.jdbc:mariadb-java-client (maven), affecting versions >= 3.0.0, < 3.3.7. It is fixed in 3.3.7, 3.4.5, 3.5.11.
  2. How severe is CVE-2026-119281? CVE-2026-119281 has a CVSS score of 5.9 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of org.mariadb.jdbc:mariadb-java-client are affected by CVE-2026-119281? org.mariadb.jdbc:mariadb-java-client (maven) versions >= 3.0.0, < 3.3.7 is affected.
  4. Is there a fix for CVE-2026-119281? Yes. CVE-2026-119281 is fixed in 3.3.7, 3.4.5, 3.5.11. Upgrade to this version or later.
  5. Is CVE-2026-119281 exploitable, and should I be worried? Whether CVE-2026-119281 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-119281 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-119281?
    • Upgrade org.mariadb.jdbc:mariadb-java-client to 3.3.7 or later
    • Upgrade org.mariadb.jdbc:mariadb-java-client to 3.4.5 or later
    • Upgrade org.mariadb.jdbc:mariadb-java-client to 3.5.11 or later

Other vulnerabilities in org.mariadb.jdbc:mariadb-java-client

Stop the waste.
Protect your environment with Kodem.