CVE-2026-19484

CVE-2026-19484 is a high-severity security vulnerability in @fastify/busboy (npm), affecting versions >= 3.1.0, < 3.2.1. It is fixed in 3.2.1.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

@fastify/busboy vulnerable to Denial of Service via oversized multipart boundary

Workarounds

Validate the multipart boundary before parsing and reject any boundary longer than the RFC 2046 limit of 70 characters (for example at a reverse proxy or in an onRequest hook). Upgrading to 3.2.1 removes the issue.

Impact

Versions of @fastify/busboy from 3.1.0 and prior to 3.2.1 are vulnerable to a Denial of Service. The vendored streaming multipart search stores its default skip distance in a Uint8Array(256). A multipart boundary of exactly 252 bytes makes the search needle 256 bytes, and the table entry wraps to zero, so a crafted request keeps the search in a CPU-bound loop and stalls the Node.js event loop. An unauthenticated client can trigger this with a single small request. Applications that use @fastify/busboy to parse multipart/form-data, directly or through @fastify/multipart, are affected.

CVE-2026-19484 has a CVSS score of 7.5 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.2.1); upgrading removes the vulnerable code path.

Affected versions

@fastify/busboy (>= 3.1.0, < 3.2.1)

Security releases

@fastify/busboy → 3.2.1 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in version 3.2.1.

Frequently Asked Questions

  1. What is CVE-2026-19484? CVE-2026-19484 is a high-severity security vulnerability in @fastify/busboy (npm), affecting versions >= 3.1.0, < 3.2.1. It is fixed in 3.2.1.
  2. How severe is CVE-2026-19484? CVE-2026-19484 has a CVSS score of 7.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @fastify/busboy are affected by CVE-2026-19484? @fastify/busboy (npm) versions >= 3.1.0, < 3.2.1 is affected.
  4. Is there a fix for CVE-2026-19484? Yes. CVE-2026-19484 is fixed in 3.2.1. Upgrade to this version or later.
  5. Is CVE-2026-19484 exploitable, and should I be worried? Whether CVE-2026-19484 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-19484 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-19484? Upgrade @fastify/busboy to 3.2.1 or later.

Other vulnerabilities in @fastify/busboy

Stop the waste.
Protect your environment with Kodem.