CVE-2026-56744

CVE-2026-56744 is a high-severity security vulnerability in @bsv/wallet-toolbox (npm), affecting versions >= 1.1.47, < 2.4.0. It is fixed in 2.4.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

@bsv/wallet-toolbox / -client / -mobile don't verify storage-supplied recipient output scripts against caller-requested outputs in createAction

Reported by @echennells (Eric Chennells). Migrated from public issue #191 to a private advisory.

Affected: @bsv/wallet-toolbox / -client / -mobile. Verified in 2.1.21 and 2.1.21-parity-fix.2; the relevant code is the same at current HEAD

Summary:
When createAction runs against a remote StorageClient, the storage server returns the outputs to build. buildSignableTransaction takes each non-change output's lockingScript from the storage response and signs it, without comparing it to the lockingScript the caller supplied in args.outputs. WalletPermissionsManager.createAction parses the built transaction and has args.outputs available, but uses the tx only for inputs and getFee(); it does not inspect tx.outputs. A storage provider that returns a different recipient script than requested will therefore have that script signed and broadcast, while the calling app and UI still show the originally requested recipient.

Relevant code:

  • signer/methods/buildSignableTransaction.js, non-change output lockingScript = asBsvSdkScript(out.lockingScript), sourced from the storage response; args.outputs is not consulted.
  • WalletPermissionsManager.js createAction, parses the built tx, derives spend from args.outputs satoshis + tx.getFee(), reads tx.inputs; does not read tx.outputs.
  • signer/methods/signAction.js, completeSignedTransaction.js, sign the as-built tx; no output comparison.

Context:
Remote storage is a supported, default configuration (StorageClient over BRC-103 AuthFetch, default endpoint storage.babbage.systems, optional payment middleware). The mutual auth establishes the storage server's identity and protects the channel, but the contents it returns are not validated against the request. The attacker is the storage operator, or anyone who compromises it, not a passive network MITM. (StorageServer.processAction does compare the signed rawTx outputs to what storage stored, so a response-only MITM is rejected; an operator stores the substituted script from the start.)

Proof of concept:
We ran a storage server that returns a substituted recipient output, and pointed a current yours-wallet build at it as its active storage provider. With the wallet otherwise unmodified, a payment requested to one address was built, signed, and broadcast paying a different address, the substitution was not surfaced anywhere in the wallet.

Impact

Affected versions

@bsv/wallet-toolbox (>= 1.1.47, < 2.4.0) @bsv/wallet-toolbox-client (>= 1.1.47, < 2.4.0) @bsv/wallet-toolbox-mobile (>= 1.3.21, < 2.4.0)

Security releases

@bsv/wallet-toolbox → 2.4.0 (npm) @bsv/wallet-toolbox-client → 2.4.0 (npm) @bsv/wallet-toolbox-mobile → 2.4.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

@bsv/wallet-toolbox to 2.4.0 or later; @bsv/wallet-toolbox-client to 2.4.0 or later; @bsv/wallet-toolbox-mobile to 2.4.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-56744? CVE-2026-56744 is a high-severity security vulnerability in @bsv/wallet-toolbox (npm), affecting versions >= 1.1.47, < 2.4.0. It is fixed in 2.4.0.
  2. Which packages are affected by CVE-2026-56744?
    • @bsv/wallet-toolbox (npm) (versions >= 1.1.47, < 2.4.0)
    • @bsv/wallet-toolbox-client (npm) (versions >= 1.1.47, < 2.4.0)
    • @bsv/wallet-toolbox-mobile (npm) (versions >= 1.3.21, < 2.4.0)
  3. Is there a fix for CVE-2026-56744? Yes. CVE-2026-56744 is fixed in 2.4.0. Upgrade to this version or later.
  4. Is CVE-2026-56744 exploitable, and should I be worried? Whether CVE-2026-56744 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  5. What actually determines whether CVE-2026-56744 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  6. How do I fix CVE-2026-56744?
    • Upgrade @bsv/wallet-toolbox to 2.4.0 or later
    • Upgrade @bsv/wallet-toolbox-client to 2.4.0 or later
    • Upgrade @bsv/wallet-toolbox-mobile to 2.4.0 or later

Stop the waste.
Protect your environment with Kodem.