CVE-2026-56811

CVE-2026-56811 is a high-severity allocation of resources without limits or throttling vulnerability in phoenix (erlang), affecting versions >= 0.11.0, < 1.5.15. It is fixed in 1.5.15, 1.6.17, 1.7.24, 1.8.9.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Phoenix: Unbounded channel joins per transport enables DoS over few connections

Phoenix transports do not limit the number of channels in a given connection, making it easy to spawn hundreds of thousands of processes over a single connection, and, eventually reaching the max processes VM limit. The solution is to limit the number of channels per transport, so an attacker needs to start new HTTP/WebSocket connections, allowing third-party services to apply rate limits and intervene more easily.

Impact

An unauthenticated remote attacker can cause a denial of service against any Phoenix app that exposes LongPoll/WebSocket transports.

The application allocates resources such as memory, threads, or file descriptors based on untrusted input without enforcing a cap. Typical impact: resource exhaustion leading to denial of service.

CVE-2026-56811 has a CVSS score of 7.5 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.5.15, 1.6.17, 1.7.24, 1.8.9); upgrading removes the vulnerable code path.

Affected versions

phoenix (>= 0.11.0, < 1.5.15) phoenix (>= 1.6.0-rc.0, < 1.6.17) phoenix (>= 1.7.0-rc.0, < 1.7.24) phoenix (>= 1.8.0-rc.0, < 1.8.9)

Security releases

phoenix → 1.5.15 (erlang) phoenix → 1.6.17 (erlang) phoenix → 1.7.24 (erlang) phoenix → 1.8.9 (erlang)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

phoenix to 1.5.15 or later; phoenix to 1.6.17 or later; phoenix to 1.7.24 or later; phoenix to 1.8.9 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-56811? CVE-2026-56811 is a high-severity allocation of resources without limits or throttling vulnerability in phoenix (erlang), affecting versions >= 0.11.0, < 1.5.15. It is fixed in 1.5.15, 1.6.17, 1.7.24, 1.8.9. The application allocates resources such as memory, threads, or file descriptors based on untrusted input without enforcing a cap.
  2. How severe is CVE-2026-56811? CVE-2026-56811 has a CVSS score of 7.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of phoenix are affected by CVE-2026-56811? phoenix (erlang) versions >= 0.11.0, < 1.5.15 is affected.
  4. Is there a fix for CVE-2026-56811? Yes. CVE-2026-56811 is fixed in 1.5.15, 1.6.17, 1.7.24, 1.8.9. Upgrade to this version or later.
  5. Is CVE-2026-56811 exploitable, and should I be worried? Whether CVE-2026-56811 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-56811 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-56811?
    • Upgrade phoenix to 1.5.15 or later
    • Upgrade phoenix to 1.6.17 or later
    • Upgrade phoenix to 1.7.24 or later
    • Upgrade phoenix to 1.8.9 or later

Other vulnerabilities in phoenix

Stop the waste.
Protect your environment with Kodem.