CVE-2026-59707

CVE-2026-59707 is a critical-severity server-side request forgery (SSRF) vulnerability in github.com/mudler/LocalAI (go), affecting versions < 1.40.1-0.20260703213242-2cbb3c96b34d. It is fixed in 1.40.1-0.20260703213242-2cbb3c96b34d.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

LocalAI POST /models/apply permits unauthenticated server-side request forgery through gallery URLs

LocalAI contains an unauthenticated server-side request forgery vulnerability in the POST /models/apply endpoint that allows attackers to fetch arbitrary internal URLs. The endpoint passes unsanitized gallery URL fields directly to gallery.GetGalleryConfigFromURLWithContext without proper validation, enabling attackers to force the server to issue HTTP GET requests to private and loopback ranges with partial response content leaked through error messages.

Impact

Untrusted input controls the target URL of a server-initiated request, which may reach internal services not otherwise accessible from outside. Typical impact: access to internal metadata services, internal APIs, or cloud credentials.

CVE-2026-59707 has a CVSS score of 8.6 (Critical). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.40.1-0.20260703213242-2cbb3c96b34d); upgrading removes the vulnerable code path.

Affected versions

github.com/mudler/LocalAI (< 1.40.1-0.20260703213242-2cbb3c96b34d)

Security releases

github.com/mudler/LocalAI → 1.40.1-0.20260703213242-2cbb3c96b34d (go)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade github.com/mudler/LocalAI to 1.40.1-0.20260703213242-2cbb3c96b34d or later to resolve this vulnerability.

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-59707? CVE-2026-59707 is a critical-severity server-side request forgery (SSRF) vulnerability in github.com/mudler/LocalAI (go), affecting versions < 1.40.1-0.20260703213242-2cbb3c96b34d. It is fixed in 1.40.1-0.20260703213242-2cbb3c96b34d. Untrusted input controls the target URL of a server-initiated request, which may reach internal services not otherwise accessible from outside.
  2. How severe is CVE-2026-59707? CVE-2026-59707 has a CVSS score of 8.6 (Critical). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of github.com/mudler/LocalAI are affected by CVE-2026-59707? github.com/mudler/LocalAI (go) versions < 1.40.1-0.20260703213242-2cbb3c96b34d is affected.
  4. Is there a fix for CVE-2026-59707? Yes. CVE-2026-59707 is fixed in 1.40.1-0.20260703213242-2cbb3c96b34d. Upgrade to this version or later.
  5. Is CVE-2026-59707 exploitable, and should I be worried? Whether CVE-2026-59707 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-59707 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-59707? Upgrade github.com/mudler/LocalAI to 1.40.1-0.20260703213242-2cbb3c96b34d or later.

Other vulnerabilities in github.com/mudler/LocalAI

Stop the waste.
Protect your environment with Kodem.