CVE-2026-61685

CVE-2026-61685 is a high-severity SQL injection vulnerability in @fecommunity/reactpress (npm), affecting versions <= 3.6.0. It is fixed in 3.7.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

ReactPress has SQL injection via dynamic column names in TypeORM query builders

ReactPress API list endpoints build TypeORM QueryBuilder conditions using
unsanitized HTTP query parameter names as SQL column identifiers
(e.g. `article.${key}`). TypeORM parameterizes values but not column
names, allowing unauthenticated attackers to inject SQL through crafted
query string keys.

Affected endpoints (unauthenticated GET)

  • GET /api/article
  • GET /api/comment
  • GET /api/file
  • GET /api/page
  • GET /api/Knowledge

Affected code

Vulnerable pattern in findAll() methods, including but not limited to:

  • server/src/modules/article/article.service.ts
  • server/src/modules/comment/comment.service.ts
  • server/src/modules/file/file.service.ts
  • server/src/modules/page/page.service.ts
  • server/src/modules/knowledge/knowledge.service.ts

Credit

Reported by lsr365400.

Impact

An unauthenticated remote attacker can perform blind SQL injection against
the application database, potentially exfiltrating sensitive data (users,
settings, API keys, article content, etc.).

Untrusted input alters a database query, allowing the attacker to read or modify data the query was not intended to access. Typical impact: data disclosure or modification.

CVE-2026-61685 has a CVSS score of 7.5 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.7.0); upgrading removes the vulnerable code path.

Affected versions

@fecommunity/reactpress (<= 3.6.0)

Security releases

@fecommunity/reactpress → 3.7.0 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

  • Whitelist allowed filter column names before interpolating into SQL.
  • Upgrade to @fecommunity/reactpress >= 3.7.0.

Frequently Asked Questions

  1. What is CVE-2026-61685? CVE-2026-61685 is a high-severity SQL injection vulnerability in @fecommunity/reactpress (npm), affecting versions <= 3.6.0. It is fixed in 3.7.0. Untrusted input alters a database query, allowing the attacker to read or modify data the query was not intended to access.
  2. How severe is CVE-2026-61685? CVE-2026-61685 has a CVSS score of 7.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @fecommunity/reactpress are affected by CVE-2026-61685? @fecommunity/reactpress (npm) versions <= 3.6.0 is affected.
  4. Is there a fix for CVE-2026-61685? Yes. CVE-2026-61685 is fixed in 3.7.0. Upgrade to this version or later.
  5. Is CVE-2026-61685 exploitable, and should I be worried? Whether CVE-2026-61685 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-61685 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-61685? Upgrade @fecommunity/reactpress to 3.7.0 or later.

Stop the waste.
Protect your environment with Kodem.