CVE-2026-62264

CVE-2026-62264 is a high-severity improper authentication vulnerability in @sylphx/pdf-reader-mcp (npm), affecting versions >= 2.2.0, < 3.0.1. It is fixed in 3.0.1.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

@sylphx/pdf-reader-mcp: HTTP transport accepts unauthenticated requests despite a configured MCPAPIKEY

Workarounds

For deployments that cannot upgrade immediately:

  • Bind to loopback only: MCP_HTTP_HOST=127.0.0.1.
  • Place a reverse proxy in front that enforces authentication.
  • Use the default stdio transport instead of HTTP.
  • Restrict filesystem reach with --allow-dir / MCP_PDF_ALLOWED_DIRS.

Reported privately by novice-22 via responsible disclosure.

Impact

When @sylphx/pdf-reader-mcp is run as an HTTP server (MCP_TRANSPORT=http), it reads the MCP_API_KEY environment variable and logs API key authentication enabled (X-API-Key header) at startup, but it never validated the X-API-Key header on incoming requests. The key was read into a variable and never enforced on the request path.

As a result, the /mcp endpoint accepted unauthenticated requests. Combined with the default bind address of 0.0.0.0 (all interfaces), any client able to reach the port could invoke every PDF tool and read the contents of any PDF the server process could open anywhere on the host. URL-based sources also enable limited SSRF (private/loopback addresses are blocked by default unless --allow-private-ips is set).

The misleading startup log made the exposure silent: an operator who set MCP_API_KEY reasonably believed the server was protected when it was not.

This affects only the opt-in HTTP transport; the default stdio transport is unaffected.

The application does not adequately verify the identity of a user, device, or process before granting access. Typical impact: unauthorized access to functions or data reserved for authenticated parties.

CVE-2026-62264 has a CVSS score of 7.5 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.0.1); upgrading removes the vulnerable code path.

Affected versions

@sylphx/pdf-reader-mcp (>= 2.2.0, < 3.0.1)

Security releases

@sylphx/pdf-reader-mcp → 3.0.1 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in @sylphx/[email protected]. The fix enforces the X-API-Key header with a constant-time comparison (rejecting missing/mismatched keys with HTTP 401), changes the default bind host to 127.0.0.1 (loopback), and emits a startup warning when binding a non-loopback host without an API key.

Frequently Asked Questions

  1. What is CVE-2026-62264? CVE-2026-62264 is a high-severity improper authentication vulnerability in @sylphx/pdf-reader-mcp (npm), affecting versions >= 2.2.0, < 3.0.1. It is fixed in 3.0.1. The application does not adequately verify the identity of a user, device, or process before granting access.
  2. How severe is CVE-2026-62264? CVE-2026-62264 has a CVSS score of 7.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of @sylphx/pdf-reader-mcp are affected by CVE-2026-62264? @sylphx/pdf-reader-mcp (npm) versions >= 2.2.0, < 3.0.1 is affected.
  4. Is there a fix for CVE-2026-62264? Yes. CVE-2026-62264 is fixed in 3.0.1. Upgrade to this version or later.
  5. Is CVE-2026-62264 exploitable, and should I be worried? Whether CVE-2026-62264 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-62264 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-62264? Upgrade @sylphx/pdf-reader-mcp to 3.0.1 or later.

Stop the waste.
Protect your environment with Kodem.