Summary
Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.
Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.
Impact
The application does not adequately validate input before processing it, allowing unexpected values to reach sensitive code paths. Typical impact: varies by context: data corruption, logic bypass, or denial of service.
CVE-2026-65637 has a CVSS score of 9.8 (Critical). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (11.0.25, 10.1.59, 9.0.121); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
org.apache.tomcat:tomcat-coyote to 11.0.25 or later; org.apache.tomcat:tomcat-coyote to 10.1.59 or later; org.apache.tomcat:tomcat-coyote to 9.0.121 or later; org.apache.tomcat.embed:tomcat-embed-core to 11.0.25 or later; org.apache.tomcat.embed:tomcat-embed-core to 10.1.59 or later; org.apache.tomcat.embed:tomcat-embed-core to 9.0.121 or later
Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.
Frequently Asked Questions
- What is CVE-2026-65637? CVE-2026-65637 is a critical-severity improper input validation vulnerability in org.apache.tomcat:tomcat-coyote (maven), affecting versions >= 11.0.20, < 11.0.25. It is fixed in 11.0.25, 10.1.59, 9.0.121. The application does not adequately validate input before processing it, allowing unexpected values to reach sensitive code paths.
- How severe is CVE-2026-65637? CVE-2026-65637 has a CVSS score of 9.8 (Critical). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which packages are affected by CVE-2026-65637?
org.apache.tomcat:tomcat-coyote(maven) (versions >= 11.0.20, < 11.0.25)org.apache.tomcat.embed:tomcat-embed-core(maven) (versions >= 11.0.20, < 11.0.25)
- Is there a fix for CVE-2026-65637? Yes. CVE-2026-65637 is fixed in 11.0.25, 10.1.59, 9.0.121. Upgrade to this version or later.
- Is CVE-2026-65637 exploitable, and should I be worried? Whether CVE-2026-65637 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-65637 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-65637?
- Upgrade
org.apache.tomcat:tomcat-coyoteto 11.0.25 or later - Upgrade
org.apache.tomcat:tomcat-coyoteto 10.1.59 or later - Upgrade
org.apache.tomcat:tomcat-coyoteto 9.0.121 or later - Upgrade
org.apache.tomcat.embed:tomcat-embed-coreto 11.0.25 or later - Upgrade
org.apache.tomcat.embed:tomcat-embed-coreto 10.1.59 or later - Upgrade
org.apache.tomcat.embed:tomcat-embed-coreto 9.0.121 or later
- Upgrade