Summary
Nginx UI OTP secure-session step-up is missing on sensitive mutation routes
Impact
If an attacker obtains the authenticated web session/JWT for a 2FA-enabled Nginx UI user, the secure-session boundary should limit what they can do until they also pass a fresh OTP/passkey challenge. The current route map leaves major administrative actions outside that boundary.
Depending on the victim user's privileges and deployment configuration, this can allow the attacker to:
- add, edit, or remove DNS provider credentials;
- alter certificate and ACME automation;
- create, modify, delete, or restore automatic backup jobs;
- configure S3 backup destinations and trigger S3 connection tests;
- alter DNS domains, records, or DDNS schedules through configured providers;
- restart or reload Nginx;
- enable/disable stub-status and change performance settings;
- switch sites/streams into advanced mode or change site automation bindings.
This undermines the value of the secure-session step-up for OTP-enabled accounts. I am not claiming pre-authentication access or remote code execution from this issue. The issue is missing step-up authorization for sensitive authenticated mutations.
The application does not perform an authorization check before performing a sensitive operation. Typical impact: unauthorized access to restricted functionality or data.
CVE-2026-84315 has a CVSS score of 8.3 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.9.10-0.20260703131214-23d1934099b0); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
Recommended mitigation:
- Apply
middleware.RequireSecureSession()to all high-impact authenticated mutation routes that alter server, Nginx, certificate, DNS, backup, credential, or automation state. - At minimum, protect:
- auto-backup create/modify/delete/restore/test-S3;
- DNS credential create/edit/delete;
- certificate and ACME user mutations;
- DNS domain, record, and DDNS mutations;
- Nginx reload/restart/stub-status/performance/module-cache mutation routes;
- site/stream advanced-mode, batch, auto-cert, navigation order, and health-check mutations.
- Add regression tests mirroring the existing config/site/stream security tests:
- OTP-enabled user without
X-Secure-Session-IDreceives401; - OTP-enabled user with a valid secure-session ID succeeds;
- non-OTP users retain existing behavior if that is the intended product policy.
- OTP-enabled user without
- Consider centralizing "sensitive mutation" routing to make future omissions harder.
Frequently Asked Questions
- What is CVE-2026-84315? CVE-2026-84315 is a high-severity missing authorization vulnerability in github.com/0xJacky/Nginx-UI (go), affecting versions < 1.9.10-0.20260703131214-23d1934099b0. It is fixed in 1.9.10-0.20260703131214-23d1934099b0. The application does not perform an authorization check before performing a sensitive operation.
- How severe is CVE-2026-84315? CVE-2026-84315 has a CVSS score of 8.3 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of github.com/0xJacky/Nginx-UI are affected by CVE-2026-84315? github.com/0xJacky/Nginx-UI (go) versions < 1.9.10-0.20260703131214-23d1934099b0 is affected.
- Is there a fix for CVE-2026-84315? Yes. CVE-2026-84315 is fixed in 1.9.10-0.20260703131214-23d1934099b0. Upgrade to this version or later.
- Is CVE-2026-84315 exploitable, and should I be worried? Whether CVE-2026-84315 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-84315 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-84315? Upgrade
github.com/0xJacky/Nginx-UIto 1.9.10-0.20260703131214-23d1934099b0 or later.