CVE-2026-86597

CVE-2026-86597 is a medium-severity security vulnerability in snowflake-sdk (npm), affecting versions < 3.3.0. It is fixed in 3.3.0, 4.7.3, 4.3.4, 2.2.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Snowflake drivers writes sensitive information to logs

Insertion of sensitive information into log files in the Snowflake Python, Go, JDBC, Node.js, PHP PDO, and ODBC drivers allowed authentication tokens, query-result encryption keys, pre-signed cloud-storage URLs, and SAML assertions to be written to diagnostic logs in circumstances where the available log redaction did not cover all affected log paths and data types. An attacker with read access to the log destination, whether the local filesystem, a log aggregation service, or a CI/CD artifact store, could obtain credentials and decryption keys that, if still valid at the time of access, could be used to authenticate to the corresponding Snowflake account or cloud-storage object. Successful exploitation requires read access to the log destination, and impact is bounded by credential lifetime and object scope. The fix is available in Snowflake Connector for Python v4.7.3, Snowflake Go Driver v2.2.0, Snowflake JDBC Driver v4.3.4 (including the snowflake-jdbc-fips and snowflake-jdbc-thin), Snowflake Node.js Driver v3.3.0, Snowflake PHP PDO Driver v4.2.0, and Snowflake ODBC Driver v3.20.0. Users must manually upgrade and should securely delete previously generated diagnostic logs containing sensitive information where retention is not required.

Impact

CVE-2026-86597 has a CVSS score of 6.5 (Medium). The vector is requires local access, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.3.0, 4.7.3, 4.3.4, 2.2.0); upgrading removes the vulnerable code path.

Affected versions

snowflake-sdk (< 3.3.0) snowflake-connector-python (< 4.7.3) github.com/snowflakedb/gosnowflake (<= 1.19.1) net.snowflake:snowflake-jdbc (< 4.3.4) net.snowflake:snowflake-jdbc-thin (< 4.3.4) net.snowflake:snowflake-jdbc-fips (< 4.3.4) github.com/snowflakedb/gosnowflake/v2 (< 2.2.0)

Security releases

snowflake-sdk → 3.3.0 (npm) snowflake-connector-python → 4.7.3 (pip) net.snowflake:snowflake-jdbc → 4.3.4 (maven) net.snowflake:snowflake-jdbc-thin → 4.3.4 (maven) net.snowflake:snowflake-jdbc-fips → 4.3.4 (maven) github.com/snowflakedb/gosnowflake/v2 → 2.2.0 (go)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade the following packages to resolve this vulnerability:

snowflake-sdk to 3.3.0 or later; snowflake-connector-python to 4.7.3 or later; net.snowflake:snowflake-jdbc to 4.3.4 or later; net.snowflake:snowflake-jdbc-thin to 4.3.4 or later; net.snowflake:snowflake-jdbc-fips to 4.3.4 or later; github.com/snowflakedb/gosnowflake/v2 to 2.2.0 or later

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is CVE-2026-86597? CVE-2026-86597 is a medium-severity security vulnerability in snowflake-sdk (npm), affecting versions < 3.3.0. It is fixed in 3.3.0, 4.7.3, 4.3.4, 2.2.0.
  2. How severe is CVE-2026-86597? CVE-2026-86597 has a CVSS score of 6.5 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-86597?
    • snowflake-sdk (npm) (versions < 3.3.0)
    • snowflake-connector-python (pip) (versions < 4.7.3)
    • github.com/snowflakedb/gosnowflake (go) (versions <= 1.19.1)
    • net.snowflake:snowflake-jdbc (maven) (versions < 4.3.4)
    • net.snowflake:snowflake-jdbc-thin (maven) (versions < 4.3.4)
    • net.snowflake:snowflake-jdbc-fips (maven) (versions < 4.3.4)
    • github.com/snowflakedb/gosnowflake/v2 (go) (versions < 2.2.0)
  4. Is there a fix for CVE-2026-86597? Yes. CVE-2026-86597 is fixed in 3.3.0, 4.7.3, 4.3.4, 2.2.0. Upgrade to this version or later.
  5. Is CVE-2026-86597 exploitable, and should I be worried? Whether CVE-2026-86597 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-86597 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-86597?
    • Upgrade snowflake-sdk to 3.3.0 or later
    • Upgrade snowflake-connector-python to 4.7.3 or later
    • Upgrade net.snowflake:snowflake-jdbc to 4.3.4 or later
    • Upgrade net.snowflake:snowflake-jdbc-thin to 4.3.4 or later
    • Upgrade net.snowflake:snowflake-jdbc-fips to 4.3.4 or later
    • Upgrade github.com/snowflakedb/gosnowflake/v2 to 2.2.0 or later

Other vulnerabilities in snowflake-sdk

Stop the waste.
Protect your environment with Kodem.