Summary
@payloadcms/storage-vercel-blob has access control bypass of uploads in Vercel Storage adapter
Workarounds
Upgrading to a patched version is recommended. Until you can upgrade, disable client uploads or configure the upload route’s access control to enforce the associated collection’s permissions.
Impact
In affected configurations, client upload access does not consistently align with the associated collection’s access configuration.
You are affected if:
- You use client uploads with
@payloadcms/storage-vercel-blob. - Authenticated users can access the client-upload route.
Applications that do not enable client uploads are not affected.
The application does not perform an authorization check before performing a sensitive operation. Typical impact: unauthorized access to restricted functionality or data.
CVE-2026-93363 has a CVSS score of 4.3 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.90.0, 4.0.0-canary.34); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
Client uploads now require authentication and the appropriate collection-level access before upload access is granted.
Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Frequently Asked Questions
- What is CVE-2026-93363? CVE-2026-93363 is a medium-severity missing authorization vulnerability in @payloadcms/storage-vercel-blob (npm), affecting versions >= 3.25.0, < 3.90.0. It is fixed in 3.90.0, 4.0.0-canary.34. The application does not perform an authorization check before performing a sensitive operation.
- How severe is CVE-2026-93363? CVE-2026-93363 has a CVSS score of 4.3 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of @payloadcms/storage-vercel-blob are affected by CVE-2026-93363? @payloadcms/storage-vercel-blob (npm) versions >= 3.25.0, < 3.90.0 is affected.
- Is there a fix for CVE-2026-93363? Yes. CVE-2026-93363 is fixed in 3.90.0, 4.0.0-canary.34. Upgrade to this version or later.
- Is CVE-2026-93363 exploitable, and should I be worried? Whether CVE-2026-93363 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-93363 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-93363?
- Upgrade
@payloadcms/storage-vercel-blobto 3.90.0 or later - Upgrade
@payloadcms/storage-vercel-blobto 4.0.0-canary.34 or later
- Upgrade