CVE-2026-93451

CVE-2026-93451 is a high-severity out-of-bounds write vulnerability in org.xerial.snappy:snappy-java (maven), affecting versions <= 1.1.10.8. It is fixed in 1.1.10.9.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

snappy-java: Heap buffer overflow in Snappy.uncompress*Array typed-array methods

Workarounds

Check that Snappy.uncompressedLength(input) is a multiple of the element size before calling these methods.

Impact

Snappy.uncompressCharArray, uncompressShortArray, uncompressIntArray, uncompressLongArray, uncompressFloatArray and uncompressDoubleArray sized the result array by dividing the declared uncompressed byte length by the element size, but native code wrote the full byte length. If the declared length is not a multiple of the element size, up to 7 bytes are written past the end of the Java array, corrupting the heap.

A write operation targets a memory location beyond the intended buffer boundary. Typical impact: memory corruption, crash, or arbitrary code execution.

CVE-2026-93451 has a CVSS score of 7.5 (High). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.1.10.9); upgrading removes the vulnerable code path.

Affected versions

org.xerial.snappy:snappy-java (<= 1.1.10.8)

Security releases

org.xerial.snappy:snappy-java → 1.1.10.9 (maven)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in 1.1.10.9 (#739). These methods now reject uncompressed lengths that are not a multiple of the element size with SnappyIOException.

Frequently Asked Questions

  1. What is CVE-2026-93451? CVE-2026-93451 is a high-severity out-of-bounds write vulnerability in org.xerial.snappy:snappy-java (maven), affecting versions <= 1.1.10.8. It is fixed in 1.1.10.9. A write operation targets a memory location beyond the intended buffer boundary.
  2. How severe is CVE-2026-93451? CVE-2026-93451 has a CVSS score of 7.5 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of org.xerial.snappy:snappy-java are affected by CVE-2026-93451? org.xerial.snappy:snappy-java (maven) versions <= 1.1.10.8 is affected.
  4. Is there a fix for CVE-2026-93451? Yes. CVE-2026-93451 is fixed in 1.1.10.9. Upgrade to this version or later.
  5. Is CVE-2026-93451 exploitable, and should I be worried? Whether CVE-2026-93451 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-93451 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-93451? Upgrade org.xerial.snappy:snappy-java to 1.1.10.9 or later.

Other vulnerabilities in org.xerial.snappy:snappy-java

Stop the waste.
Protect your environment with Kodem.