GHSA-44JH-23M7-HPCF

GHSA-44JH-23M7-HPCF is a low-severity race condition vulnerability in @better-auth/drizzle-adapter (npm), affecting versions >= 1.6.17, < 1.7.7. It is fixed in 1.7.7, 1.7.0.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

@better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQL

Am I affected?

You are affected if you use @better-auth/drizzle-adapter from 1.6.17 through versions before 1.7.7 (including the 1.7.0 prereleases from beta.6 through rc.6) or @better-auth/kysely-adapter 1.6.17 through 1.6.31, and keep rate-limit records in a PostgreSQL database.

All of these must be true:

  • Rate limiting is enabled.
  • Rate-limit records are stored in the database.
  • The database is PostgreSQL, used through one of the adapter versions above.

You are not affected if you store rate-limit records in memory (the default) or in secondary storage.

Database-backed rate limiting on PostgreSQL can let a burst of concurrent requests go over the configured maximum. When many requests arrive at the same time, several of them can pass the limit check together. This weakens the rate limit on password sign-in, two-factor verification, one-time codes, password resets, and other rate-limited endpoints.

Workarounds

  • Store rate-limit records in secondary storage.
  • Use a custom rate-limit storage that checks and increments the counter in one atomic step. An atomic step cannot be interrupted by another request.
  • Enforce the intended limit at an upstream layer, such as a reverse proxy or gateway.

In-memory storage also avoids this issue. However, each application instance keeps its own counter, so it may not enforce one shared limit in multi-instance or serverless deployments.

Impact

An attacker who sends many requests at once can make more attempts than the application allows.

The issue does not bypass password or one-time-code validation. It does not directly compromise an account. The number of extra attempts is limited by the number of concurrent database connections, the number of application instances, and the rate-limit window.

Multiple concurrent operations access a shared resource without proper synchronization, producing unpredictable results depending on timing. Typical impact: TOCTOU exploits, data corruption, or privilege escalation.

GHSA-44JH-23M7-HPCF has a CVSS score of 3.7 (Low). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.7.7, 1.7.0); upgrading removes the vulnerable code path.

Affected versions

@better-auth/drizzle-adapter (>= 1.6.17, < 1.7.7) @better-auth/kysely-adapter (>= 1.6.17, < 1.7.0) better-auth (>= 1.6.17, < 1.7.7)

Security releases

@better-auth/drizzle-adapter → 1.7.7 (npm) @better-auth/kysely-adapter → 1.7.0 (npm) better-auth → 1.7.7 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

@better-auth/kysely-adapter is fixed in 1.7.0. Upgrade to 1.7.0 or later.

The Drizzle fix is merged for the planned @better-auth/drizzle-adapter 1.7.7 release. That package is not available yet. Upgrade better-auth and the installed Drizzle adapter together when 1.7.7 is available. No database schema or public API migration is required.

Frequently Asked Questions

  1. What is GHSA-44JH-23M7-HPCF? GHSA-44JH-23M7-HPCF is a low-severity race condition vulnerability in @better-auth/drizzle-adapter (npm), affecting versions >= 1.6.17, < 1.7.7. It is fixed in 1.7.7, 1.7.0. Multiple concurrent operations access a shared resource without proper synchronization, producing unpredictable results depending on timing.
  2. How severe is GHSA-44JH-23M7-HPCF? GHSA-44JH-23M7-HPCF has a CVSS score of 3.7 (Low). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by GHSA-44JH-23M7-HPCF?
    • @better-auth/drizzle-adapter (npm) (versions >= 1.6.17, < 1.7.7)
    • @better-auth/kysely-adapter (npm) (versions >= 1.6.17, < 1.7.0)
    • better-auth (npm) (versions >= 1.6.17, < 1.7.7)
  4. Is there a fix for GHSA-44JH-23M7-HPCF? Yes. GHSA-44JH-23M7-HPCF is fixed in 1.7.7, 1.7.0. Upgrade to this version or later.
  5. Is GHSA-44JH-23M7-HPCF exploitable, and should I be worried? Whether GHSA-44JH-23M7-HPCF is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether GHSA-44JH-23M7-HPCF is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix GHSA-44JH-23M7-HPCF?
    • Upgrade @better-auth/drizzle-adapter to 1.7.7 or later
    • Upgrade @better-auth/kysely-adapter to 1.7.0 or later
    • Upgrade better-auth to 1.7.7 or later

Stop the waste.
Protect your environment with Kodem.