Summary
Hydra legacy target blacklist permits unsafe PyYAML loading
Hydra's legacy target blacklist omits PyYAML's unsafe loading surfaces. If an
application passes attacker-controlled targets and arguments to instantiate(),
a target such as yaml.unsafe_load can execute Python code through a
config-controlled YAML stream containing Python object-construction tags.
Impact and prerequisites
The attacker must control the relevant target and arguments that the application
instantiates. The configured callable executes with the application's process
privileges. This is a gap in the best-effort legacy blacklist. It is not a bypass
of Hydra 1.4's execution whitelist supplied by trusted Python code.
One realistic exposure is a model downloaded from a third-party repository,
such as Hugging Face, that bundles attacker-controlled configuration. When a
victim loads the model using application code that passes this configuration
to legacy Hydra instantiation without effective target restrictions, the
model's metadata can execute code in the victim process. This model-loading
attack pattern is documented in the original Hydra advisory
GHSA-2cp2-2r3c-7p7r and the associated Unit 42 research. It does not imply that
all Hugging Face models or currently patched downstream loaders are affected.
Hydra 1.3's blacklist is defense in depth, not a complete security boundary.
Hydra 1.4 is affected on its deprecated no-whitelist legacy path. Installed
application wrappers can perform indirect operations beyond a name-based
blacklist's coverage; this fix does not make arbitrary configuration safe.
The unsafe_load finding is directly reproduced. PyYAML 6.0.3 full_load rejects
the demonstrated python/object/apply payload, so the finding does not claim that
all PyYAML loading APIs execute that payload.
Workarounds
Do not pass untrusted configuration to instantiate() or call(). For Hydra 1.4,
supply a narrow execution whitelist from trusted Python code. Do not let
untrusted configuration select its own execution policy or opt out of checks.
Affected releases
The reported incomplete-remediation stable range is hydra-core 1.3.6 through
1.3.7. The 1.4 prerelease legacy path is also affected, including 1.4.0.dev9,
1.4.0.dev10, 1.4.0rc1, and 1.4.0rc2. The related blacklist advisory
GHSA-rqx7-p7vv-w7hr was first patched in 1.3.6 and 1.4.0.dev9; these ranges
describe the remaining omission after that remediation.
Credit
Reported by zx (@manus-pi).
Impact
GHSA-WF6J-7HVR-GR93 has a CVSS score of 7.8 (High). The vector is requires local access, no privileges required, and user interaction required. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.3.8, 1.4.0rc3); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
The fix blocks the yaml. target namespace except for the exact yaml.safe_load,
yaml.safe_load_all, yaml.safe_dump, and yaml.safe_dump_all functions. Loader
classes, constructor registration, general dump/load APIs, and other targets in
the namespace remain blocked. Existing canonical-identity checks also cover
aliases. The fix preserves Hydra 1.4's explicit unsafe opt-out for trusted use.
Frequently Asked Questions
- What is GHSA-WF6J-7HVR-GR93? GHSA-WF6J-7HVR-GR93 is a high-severity security vulnerability in hydra-core (pip), affecting versions >= 1.3.6, < 1.3.8. It is fixed in 1.3.8, 1.4.0rc3.
- How severe is GHSA-WF6J-7HVR-GR93? GHSA-WF6J-7HVR-GR93 has a CVSS score of 7.8 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of hydra-core are affected by GHSA-WF6J-7HVR-GR93? hydra-core (pip) versions >= 1.3.6, < 1.3.8 is affected.
- Is there a fix for GHSA-WF6J-7HVR-GR93? Yes. GHSA-WF6J-7HVR-GR93 is fixed in 1.3.8, 1.4.0rc3. Upgrade to this version or later.
- Is GHSA-WF6J-7HVR-GR93 exploitable, and should I be worried? Whether GHSA-WF6J-7HVR-GR93 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether GHSA-WF6J-7HVR-GR93 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix GHSA-WF6J-7HVR-GR93?
- Upgrade
hydra-coreto 1.3.8 or later - Upgrade
hydra-coreto 1.4.0rc3 or later
- Upgrade