Summary
Crossplane: Signature verification TOCTOU allows installing unverified package content via mutable tag
Crossplane allows package signature verification to be configured via the ImageConfig mechanism. When enabled, the package manager uses cosign to verify that packages are correctly signed before pulling and installing them.
When a package is installed using a tag reference (e.g., a semantic version), a malicious OCI registry could serve a correctly signed image for verification, then subsequently serve an unsigned image for installation. This is possible because Crossplane resolves the tag reference separately for each step.
This vulnerability is relevant only for users who do all three of the following:
- Configure signature verification for packages,
- Install packages using tag references rather than digests, and
- Install packages from registries they do not control.
Mitigation
Installing packages by image digest rather than using tags avoids this issue.
Note on Fixed Versions
The Crossplane maintainers are not planning to backport the fix for this advisory to the 1.20 branch, for two reasons:
- The advisory is relevant only when an alpha feature is enabled and configured, and has a reasonable mitigation that is already a security best practice.
- Doing so would require a major refactor of package manager internals to match the refactor that shipped in Crossplane v2.2. Such a refactor would be an unnecessary risk given the policy that v1.20 receives only critical fixes and that this advisory affects only users of an alpha feature.
Credits
This issue was reported, independently, by @bugbunny-research and @tonghuaroot.
Impact
GHSA-WFQX-GJRF-G28R has a CVSS score of 9.0 (Critical). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (2.3.3, 2.2.3); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
The package manager has been updated to resolve tag references once and use the resulting digest for both signature verification and image fetching. This ensures that Crossplane pulls the same content that had its signature verified. The fix has been applied to Crossplane's main branch and backported to the v2.3 and v2.2 release branches; it will be released in v2.3.3 and v2.2.3.
Frequently Asked Questions
- What is GHSA-WFQX-GJRF-G28R? GHSA-WFQX-GJRF-G28R is a critical-severity security vulnerability in github.com/crossplane/crossplane/v2 (go), affecting versions >= 2.3.0-rc.0, <= 2.3.2. It is fixed in 2.3.3, 2.2.3.
- How severe is GHSA-WFQX-GJRF-G28R? GHSA-WFQX-GJRF-G28R has a CVSS score of 9.0 (Critical). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which packages are affected by GHSA-WFQX-GJRF-G28R?
github.com/crossplane/crossplane/v2(go) (versions >= 2.3.0-rc.0, <= 2.3.2)github.com/crossplane/crossplane(go) (versions <= 1.21.0-rc.0)
- Is there a fix for GHSA-WFQX-GJRF-G28R? Yes. GHSA-WFQX-GJRF-G28R is fixed in 2.3.3, 2.2.3. Upgrade to this version or later.
- Is GHSA-WFQX-GJRF-G28R exploitable, and should I be worried? Whether GHSA-WFQX-GJRF-G28R is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether GHSA-WFQX-GJRF-G28R is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix GHSA-WFQX-GJRF-G28R?
- Upgrade
github.com/crossplane/crossplane/v2to 2.3.3 or later - Upgrade
github.com/crossplane/crossplane/v2to 2.2.3 or later
- Upgrade