CVE-2026-106449

CVE-2026-106449 is a low-severity security vulnerability in at.yawk.lz4:lz4-java (maven), affecting versions <= 1.11.3. It is fixed in 1.11.4.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

yawkat LZ4 Java: LZ4BlockInputStream with stopOnEmptyBlock=false recurses once per empty block, causing StackOverflowError

When LZ4BlockInputStream is configured with stopOnEmptyBlock = false (the mode for reading concatenated block streams), it handles each empty block by calling refill() recursively. A long run of empty blocks exhausts the thread stack and throws StackOverflowError out of read() or skip().

Details

In net.jpountz.lz4.LZ4BlockInputStream.refill():

if (originalLen == 0 && compressedLen == 0) {
  if (check != 0) {
    throw new IOException("Stream is corrupted");
  }
  if (!stopOnEmptyBlock) {
    refill();
  } else {
    finished = true;
  }
  return;
}

Each well-formed empty block is 21 bytes and adds one stack frame, with no limit on nesting depth. In local testing, around 10,000 to 100,000 consecutive empty blocks (about 210 KB to 2.1 MB, depending on JIT state and thread stack size) threw StackOverflowError. StackOverflowError is an Error, not an IOException, so callers that only handle I/O errors for corrupt input don't catch it.

Impact

Applications that decode attacker-controlled LZ4Block streams with LZ4BlockInputStream.newBuilder().withStopOnEmptyBlock(false) or the deprecated LZ4BlockInputStream(InputStream, boolean) constructor can have the decoding thread fail with StackOverflowError. The default configuration (stopOnEmptyBlock = true) is not affected. There is no memory corruption. Availability impact only.

CVE-2026-106449 has a CVSS score of 3.7 (Low). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.11.4); upgrading removes the vulnerable code path.

Affected versions

at.yawk.lz4:lz4-java (<= 1.11.3) org.lz4:lz4-java (<= 1.8.1)

Security releases

at.yawk.lz4:lz4-java → 1.11.4 (maven)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

Fixed in lz4-java 1.11.4. Empty blocks are now skipped in a loop instead of by recursion, so any number of consecutive empty blocks uses constant stack space.

For older versions, the workaround is to use the default stopOnEmptyBlock = true for untrusted input, or catch StackOverflowError around the read loop.

Frequently Asked Questions

  1. What is CVE-2026-106449? CVE-2026-106449 is a low-severity security vulnerability in at.yawk.lz4:lz4-java (maven), affecting versions <= 1.11.3. It is fixed in 1.11.4.
  2. How severe is CVE-2026-106449? CVE-2026-106449 has a CVSS score of 3.7 (Low). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-106449?
    • at.yawk.lz4:lz4-java (maven) (versions <= 1.11.3)
    • org.lz4:lz4-java (maven) (versions <= 1.8.1)
  4. Is there a fix for CVE-2026-106449? Yes. CVE-2026-106449 is fixed in 1.11.4. Upgrade to this version or later.
  5. Is CVE-2026-106449 exploitable, and should I be worried? Whether CVE-2026-106449 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106449 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106449? Upgrade at.yawk.lz4:lz4-java to 1.11.4 or later.

Other vulnerabilities in at.yawk.lz4:lz4-java

Stop the waste.
Protect your environment with Kodem.