CVE-2026-106452

CVE-2026-106452 is a medium-severity security vulnerability in at.yawk.lz4:lz4-java (maven), affecting versions <= 1.11.1. It is fixed in 1.11.2.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

yawkat LZ4 Java: LZ4BlockInputStream allocates an unvalidated compressed length from the stream header

LZ4BlockInputStream grows its compressed-input buffer to the attacker-controlled compressedLen value from the legacy LZ4Block stream header before reading any payload bytes. A header-only input can therefore trigger a near-2 GiB allocation and exhaust the JVM heap.

Details

In net.jpountz.lz4.LZ4BlockInputStream, refill() validates that compressedLen is nonnegative but does not cap it before allocation:

case COMPRESSION_METHOD_LZ4:
  if (compressedBuffer.length < compressedLen) {
    compressedBuffer = new byte[Math.max(compressedLen, compressedBuffer.length * 3 / 2)];
  }
  readFully(compressedBuffer, compressedLen);

The paired LZ4BlockOutputStream never emits such a block. If compression is not smaller than the original block, it writes the block as RAW:

if (compressedLength >= o) {
  compressMethod = COMPRESSION_METHOD_RAW;
  compressedLength = o;
} else {
  compressMethod = COMPRESSION_METHOD_LZ4;
}

Existing readers generally accept noncanonical LZ4-method blocks where compressedLen >= originalLen, but no canonical writer found produces them.

Impact

Applications that pass attacker-controlled legacy LZ4Block streams to LZ4BlockInputStream can suffer heap exhaustion from a header-only input. The impact is availability-only and requires no valid compressed payload.

CVE-2026-106452 has a CVSS score of 5.3 (Medium). The vector is network-reachable, no privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (1.11.2); upgrading removes the vulnerable code path.

Affected versions

at.yawk.lz4:lz4-java (<= 1.11.1) org.lz4:lz4-java (<= 1.8.1)

Security releases

at.yawk.lz4:lz4-java → 1.11.2 (maven)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

As of lz4-java 1.11.2, lz4-java rejects lz4 blocks where the compressed length is larger than uncompressed. Readers would generally emit these as raw blocks instead. You can use the new acceptOversizedBlocks flag to restore the old behavior, but this reintroduces the DoS vector.

Frequently Asked Questions

  1. What is CVE-2026-106452? CVE-2026-106452 is a medium-severity security vulnerability in at.yawk.lz4:lz4-java (maven), affecting versions <= 1.11.1. It is fixed in 1.11.2.
  2. How severe is CVE-2026-106452? CVE-2026-106452 has a CVSS score of 5.3 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-106452?
    • at.yawk.lz4:lz4-java (maven) (versions <= 1.11.1)
    • org.lz4:lz4-java (maven) (versions <= 1.8.1)
  4. Is there a fix for CVE-2026-106452? Yes. CVE-2026-106452 is fixed in 1.11.2. Upgrade to this version or later.
  5. Is CVE-2026-106452 exploitable, and should I be worried? Whether CVE-2026-106452 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106452 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106452? Upgrade at.yawk.lz4:lz4-java to 1.11.2 or later.

Other vulnerabilities in at.yawk.lz4:lz4-java

Stop the waste.
Protect your environment with Kodem.