CVE-2026-106462

CVE-2026-106462 is a medium-severity incorrect authorization vulnerability in @backstage/plugin-scaffolder-backend (npm), affecting versions < 4.1.0. It is fixed in 4.1.0, 0.9.13, 0.11.10, 0.2.25, 0.3.10.

Does this CVE actually affect you?

Kodem shows which CVEs are reachable and running in your applications, so you fix what's exploitable, not just what's listed.

Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Runtime intelligence, not another scanner.

Summary

Backstage's scaffolder credential handling may allow unintended GitHub authentication fallback

Workarounds

If you cannot upgrade and enable the setting immediately:

  • Restrict who can create Scaffolder tasks and which templates they can execute.
  • Limit SCM integration credentials to the minimum repository read and mutation permissions required.
  • Remove integration credentials for SCM hosts where all required operations can use explicitly supplied user tokens.

Impact

Scaffolder actions that interact with source control systems may not consistently enforce the intended credential boundaries under certain configurations. An authenticated user could perform operations with broader access than intended.

The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions. Typical impact: unauthorized data access or execution of privileged operations.

CVE-2026-106462 has a CVSS score of 6.4 (Medium). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (4.1.0, 0.9.13, 0.11.10, 0.2.25, 0.3.10); upgrading removes the vulnerable code path.

Affected versions

@backstage/plugin-scaffolder-backend (< 4.1.0) @backstage/plugin-scaffolder-backend-module-github (< 0.9.13) @backstage/plugin-scaffolder-backend-module-gitlab (< 0.11.10) @backstage/plugin-scaffolder-backend-module-azure (< 0.2.25) @backstage/plugin-scaffolder-backend-module-bitbucket-cloud (< 0.3.10) @backstage/plugin-scaffolder-backend-module-bitbucket-server (< 0.2.25)

Security releases

@backstage/plugin-scaffolder-backend → 4.1.0 (npm) @backstage/plugin-scaffolder-backend-module-github → 0.9.13 (npm) @backstage/plugin-scaffolder-backend-module-gitlab → 0.11.10 (npm) @backstage/plugin-scaffolder-backend-module-azure → 0.2.25 (npm) @backstage/plugin-scaffolder-backend-module-bitbucket-cloud → 0.3.10 (npm) @backstage/plugin-scaffolder-backend-module-bitbucket-server → 0.2.25 (npm)

Kodem intelligence

Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.

Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.

Already deployed Kodem?

See it in your environmentNew to Kodem? Get a demo →

Remediation advice

  • @backstage/plugin-scaffolder-backend version 4.1.0
  • @backstage/plugin-scaffolder-backend-module-azure version 0.2.25
  • @backstage/plugin-scaffolder-backend-module-bitbucket-cloud version 0.3.10
  • @backstage/plugin-scaffolder-backend-module-bitbucket-server version 0.2.25
  • @backstage/plugin-scaffolder-backend-module-github version 0.9.13
  • @backstage/plugin-scaffolder-backend-module-gitlab version 0.11.10

The fix introduces a new configuration option that enforces user-provided credentials for supported SCM actions. The new behavior is opt-in for compatibility. After upgrading, set:

scaffolder:
  requireScmUserCredentials: true

Before enabling this setting, review and update your templates as described in the software templates documentation referred to below.

Frequently Asked Questions

  1. What is CVE-2026-106462? CVE-2026-106462 is a medium-severity incorrect authorization vulnerability in @backstage/plugin-scaffolder-backend (npm), affecting versions < 4.1.0. It is fixed in 4.1.0, 0.9.13, 0.11.10, 0.2.25, 0.3.10. The application does not correctly enforce access controls, allowing a principal to access resources or operations beyond their granted permissions.
  2. How severe is CVE-2026-106462? CVE-2026-106462 has a CVSS score of 6.4 (Medium). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
  3. Which packages are affected by CVE-2026-106462?
    • @backstage/plugin-scaffolder-backend (npm) (versions < 4.1.0)
    • @backstage/plugin-scaffolder-backend-module-github (npm) (versions < 0.9.13)
    • @backstage/plugin-scaffolder-backend-module-gitlab (npm) (versions < 0.11.10)
    • @backstage/plugin-scaffolder-backend-module-azure (npm) (versions < 0.2.25)
    • @backstage/plugin-scaffolder-backend-module-bitbucket-cloud (npm) (versions < 0.3.10)
    • @backstage/plugin-scaffolder-backend-module-bitbucket-server (npm) (versions < 0.2.25)
  4. Is there a fix for CVE-2026-106462? Yes. CVE-2026-106462 is fixed in 4.1.0, 0.9.13, 0.11.10, 0.2.25, 0.3.10. Upgrade to this version or later.
  5. Is CVE-2026-106462 exploitable, and should I be worried? Whether CVE-2026-106462 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
  6. What actually determines whether CVE-2026-106462 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
  7. How do I fix CVE-2026-106462?
    • Upgrade @backstage/plugin-scaffolder-backend to 4.1.0 or later
    • Upgrade @backstage/plugin-scaffolder-backend-module-github to 0.9.13 or later
    • Upgrade @backstage/plugin-scaffolder-backend-module-gitlab to 0.11.10 or later
    • Upgrade @backstage/plugin-scaffolder-backend-module-azure to 0.2.25 or later
    • Upgrade @backstage/plugin-scaffolder-backend-module-bitbucket-cloud to 0.3.10 or later
    • Upgrade @backstage/plugin-scaffolder-backend-module-bitbucket-server to 0.2.25 or later

Other vulnerabilities in @backstage/plugin-scaffolder-backend

Stop the waste.
Protect your environment with Kodem.