Summary
Backstage: Scaffolder action input authorization bypass
Workarounds
- Restrict affected Scaffolder actions to trusted users and configure source-control integrations with least-privilege credentials.
Impact
An authenticated user with access to affected Scaffolder templates could bypass configured action restrictions. Depending on integration credentials, this could grant unauthorized access to repositories and related source-control resources.
CVE-2026-106503 has a CVSS score of 8.1 (High). The vector is network-reachable, low privileges required, and no user interaction. A CVSS score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether this affects your application depends on whether the vulnerable code is present and reachable in your environment. A fixed version is available (3.3.1, 3.4.1, 4.0.3, 4.1.0); upgrading removes the vulnerable code path.
Affected versions
Security releases
Kodem intelligence
Severity tells you how bad this could be in the worst case. It does not tell you whether you are exposed. Exploitability and impact are functions of runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A vulnerable package can sit in your dependency tree and never run.
Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter. Kodem's runtime-powered SCA identifies whether this CVE is reachable in your applications.
Already deployed Kodem?
See it in your environmentNew to Kodem? Get a demo →Remediation advice
Patched in @backstage/plugin-scaffolder-backend version 4.1.0
Frequently Asked Questions
- What is CVE-2026-106503? CVE-2026-106503 is a high-severity security vulnerability in @backstage/plugin-scaffolder-backend (npm), affecting versions < 3.3.1. It is fixed in 3.3.1, 3.4.1, 4.0.3, 4.1.0.
- How severe is CVE-2026-106503? CVE-2026-106503 has a CVSS score of 8.1 (High). This score reflects the worst-case severity of the vulnerability, not your specific exposure. Whether it represents real risk in your environment depends on whether the vulnerable code is present and reachable.
- Which versions of @backstage/plugin-scaffolder-backend are affected by CVE-2026-106503? @backstage/plugin-scaffolder-backend (npm) versions < 3.3.1 is affected.
- Is there a fix for CVE-2026-106503? Yes. CVE-2026-106503 is fixed in 3.3.1, 3.4.1, 4.0.3, 4.1.0. Upgrade to this version or later.
- Is CVE-2026-106503 exploitable, and should I be worried? Whether CVE-2026-106503 is exploitable in your environment depends on whether the vulnerable code is present and reachable. A CVSS score is a worst-case rating; it does not account for your specific deployment, configuration, or usage patterns. Kodem, an Intelligent Application Security platform, uses runtime intelligence to show which vulnerabilities actually execute in production, so you can focus on the ones that represent real risk. Get a demo
- What actually determines whether CVE-2026-106503 is exploitable, and how bad it is? Exploitability and impact are not fixed properties of a CVE. They depend on runtime truth: whether the vulnerable code is present, reachable, and actually executes in your application. A high CVSS score on a dependency that never runs is not the same as real risk. Kodem, an Intelligent Application Security platform, uses runtime intelligence to reveal which vulnerabilities actually execute in production, so teams prioritize the ones that genuinely matter.
- How do I fix CVE-2026-106503?
- Upgrade
@backstage/plugin-scaffolder-backendto 3.3.1 or later - Upgrade
@backstage/plugin-scaffolder-backendto 3.4.1 or later - Upgrade
@backstage/plugin-scaffolder-backendto 4.0.3 or later - Upgrade
@backstage/plugin-scaffolder-backendto 4.1.0 or later
- Upgrade